This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 487757 - emacs redisplay extremely slow
emacs redisplay extremely slow
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 14:01 EST by Per Bothner
Modified: 2009-09-22 03:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 03:22:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Per Bothner 2009-02-27 14:01:51 EST
Description of problem:

Starting around Feb 18, emacs in Rawhide became slow as molasses when redisplaying in an X window:  Any scrolling or redisplay (even when only scrolling by a single line), the whole window is redisplayed, and
it is done so very slowly - taking about two seconds.

This make using emacs extremely painful.

This is only a problem with the default "X window" emacs - it is not a problem with emacs -nw (i.e. Emacs in a terminal window).

This might be an X driver problem - but it doesn't seem to affect other programs I've tried, including other text editors (kate, gedit). 
It seems to be using the "intel" driver, though X.log.0 also makes reference to "i810".  The hardware is a Lenovo T400 Thinkpad with a 4500MHD.

Version-Release number of selected component (if applicable):

Rawhide as of today.
Emacs-22.3.1.
X.Org X Server 1.6.0, Release Date: 2009-2-25.

How reproducible:

Always.

Steps to Reproduce:

Open a file in Emacs that is bigger than a screen, and scroll.
Or partially obscure it and re-display.
Comment 1 Rakesh Pandit 2009-03-10 04:45:21 EDT
emacs-22.3-8.fc11.i586
xorg-x11-server-Xorg-1.6.0-9.fc11.i586

With these installed I can confirm the problem. With file scrolling the file update lag is large.

The effect is similar to ssh into a far away server with very slow net connectivity and using emacs.
Comment 2 Rakesh Pandit 2009-03-10 04:57:27 EDT
If this info helps:

[root@rahul ~]# xrandr 

Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1680
VGA connected 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050      60.0*+
   1400x1050      74.8     60.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     75.0     59.9  
   720x400        70.1  
LVDS connected (normal left inverted right x axis y axis)
   1280x800       60.0 +   50.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

[root@rahul ~]# lspci  | grep Display
00:02.1 Display controller: Intel Corporation 82Q35 Express Integrated Graphics Controller (rev 02)
[root@rahul ~]#
Comment 3 Asko Tontti 2009-03-15 06:25:45 EDT
Yep, seeing also with Lenovo X300.

emacs-22.3-8.fc11.x86_64
xorg-x11-drv-intel-2.6.0-14.fc11.x86_64
xorg-x11-server-Xorg-1.6.0-9.fc11.x86_64

Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
Comment 4 Kevin Fenzi 2009-04-04 15:57:27 EDT
This might be a duplicate of 490839 ?
Comment 5 Per Bothner 2009-04-04 16:32:07 EDT
It might well be - if I enable "Desktop Effects" Emacs is suddenly quite zippy!

So I can actually use Compiz for something besides eye candy!
Comment 6 Gerd Hoffmann 2009-04-07 03:36:26 EDT
Same problem here.  I see it with xterm too.

Seems to be related to the classic bitmap font rendering

xterm -font "-*-terminus-bold-r-normal--16-*-*-*-*-*-iso10646-1"
=> slow as hell.

xterm -fa terminus:style=bold -fs 10
=> reasonable fast.
Comment 7 Asko Tontti 2009-04-10 12:40:22 EDT
Fixed by kernel-2.6.29.1-54.fc11 and xorg-x11-drv-intel-2.6.99.902-2.fc11, at least for me. See bug 490839 for more information.
Comment 8 Daniel Novotny 2009-06-01 05:52:17 EDT
hello, there's a new version 23.0.93 in rawhide: does it fix this for you?
Comment 9 Bug Zapper 2009-06-09 07:42:46 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Daniel Novotny 2009-09-21 08:02:23 EDT
hello, there's a new version 23.1 in F11 and rawhide: does it fix this for you?
Comment 11 Per Bothner 2009-09-21 13:52:06 EDT
The bug wasn't in Emacs, but in the Intel driver and/or Kernel - see comment #7.
In any case, the problem has been fixed in F11 for a while now.
We can probably close this bug.
Comment 12 Daniel Novotny 2009-09-22 03:22:26 EDT
ok, closing

Note You need to log in before you can comment on or make changes to this bug.