Bug 487829 - xterm-242 loses the terminal bell
xterm-242 loses the terminal bell
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 22:11 EST by Chris Adams
Modified: 2009-03-09 19:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: 242-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 19:01:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for this issue (will be part of #243 changes) (3.10 KB, application/octet-stream)
2009-02-28 11:01 EST, Thomas E. Dickey
no flags Details

  None (edit)
Description Chris Adams 2009-02-27 22:11:08 EST
I tried xterm-242 from updates-testing on both F9 and F10, and I lose the terminal bell in both.  Downgrading back to xterm-238 brings back the bell.
Comment 1 Miroslav Lichvar 2009-02-28 04:57:52 EST
The problem seems to be in xtermBell, it calls XBell only when percent > 0.
Comment 2 Thomas E. Dickey 2009-02-28 10:24:13 EST
agreed - I noticed it last week...
Comment 3 Thomas E. Dickey 2009-02-28 10:29:31 EST
That's a minor bug - for #243, I have in mind a larger
change, but won't be able to work on xterm til mid-March.
Comment 4 Thomas E. Dickey 2009-02-28 11:01:58 EST
Created attachment 333607 [details]
patch for this issue (will be part of #243 changes)
Comment 5 Miroslav Lichvar 2009-03-02 08:09:31 EST
Thanks, Thomas.

Fixed in xterm-242-2.fc10.
Comment 6 Fedora Update System 2009-03-02 08:12:49 EST
xterm-242-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xterm-242-2.fc10
Comment 7 Fedora Update System 2009-03-02 08:12:52 EST
xterm-242-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xterm-242-2.fc9
Comment 8 Chris Adams 2009-03-02 10:32:20 EST
I installed the update from koji on F9 (my F10 system is down at the moment) and it does fix the bell for me.  Thanks to both of you for fixing this!
Comment 9 Fedora Update System 2009-03-02 12:03:00 EST
xterm-242-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xterm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2239
Comment 10 Fedora Update System 2009-03-09 18:45:47 EDT
xterm-242-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-03-09 19:00:56 EDT
xterm-242-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.