Bug 487835 - RFE: iface name: Generated <interface> targets should contain the VM ID, helps debugging
RFE: iface name: Generated <interface> targets should contain the VM ID, help...
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks: libvirtTodoHV
  Show dependency treegraph
 
Reported: 2009-02-27 23:04 EST by Juan Urroa
Modified: 2015-04-27 17:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-27 17:02:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Urroa 2009-02-27 23:04:23 EST
Description of problem:
This a whish to have not a bug. I think it would be very practical to show the vm id in the name of the vnets created by libvirt, just like in Xen

Version-Release number of selected component (if applicable):
all

How reproducible:
create a new vm and run ifconfig it shows vnet0, vnet1,...
It should be better if the look like vnet0.0, vnet11.0 like in Xen vifs
  
Actual results:
vnet0

Expected results:
vnet0.1
Comment 1 Mark McLoughlin 2009-03-25 14:15:38 EDT
Moving to upstream libvirt bugzilla - I guess it wouldn't be difficult to implement, but would it really help much?
Comment 2 Juan Urroa 2009-09-29 19:40:05 EDT
It helps when debugging the network with wireshark
Comment 3 Cole Robinson 2015-04-27 17:02:11 EDT
This never happened and I don't really expect it ever will, so just closing. If someone still cares I suggest sending a patch to libvir-list for discussion

Note You need to log in before you can comment on or make changes to this bug.