Bug 487873 - File conflict between alsa-firmware and kernel-firmware in recent rawhide
Summary: File conflict between alsa-firmware and kernel-firmware in recent rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-firmware
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-28 15:59 UTC by Bruno Wolff III
Modified: 2009-04-14 12:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-10 17:48:04 UTC


Attachments (Terms of Use)

Description Bruno Wolff III 2009-02-28 15:59:19 UTC
Description of problem:
Trying to update to a recent rawhide kernel is blocked by a file conflict between alsa-firmware and kernel-firmware.

Version-Release number of selected component (if applicable):
alsa-firmware-1.0.19-1.fc11
kernel-firmware-2.6.29-0.172.rc6.git4.fc11

How reproducible:
100%

Steps to Reproduce:
1. yum install alsa-firmware
2.
3.
  
Actual results:
Transaction Check Error:
  file /lib/firmware/ess/maestro3_assp_kernel.fw from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/ess/maestro3_assp_minisrc.fw from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/korg/k1212.dsp from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/sb16/alaw_main.csp from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/sb16/ima_adpcm_capture.csp from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/sb16/ima_adpcm_init.csp from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/sb16/ima_adpcm_playback.csp from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/sb16/mulaw_main.csp from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/yamaha/ds1_ctrl.fw from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/yamaha/ds1_dsp.fw from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch
  file /lib/firmware/yamaha/ds1e_ctrl.fw from install of alsa-firmware-1.0.19-1.fc11.noarch conflicts with file from package kernel-firmware-2.6.29-0.172.rc6.git4.fc11.noarch


Expected results:
No errors

Additional info:

Comment 1 Tim Jackson 2009-02-28 16:48:45 UTC
Thanks for the heads-up. I've opened a discussion on fedora-kernel-list.

https://www.redhat.com/archives/fedora-kernel-list/2009-February/msg00100.html

Comment 2 Thomas Kowaliczek 2009-03-01 13:33:42 UTC
The problem is too in kernel-firmware-2.6.29-0.159.rc6.git3.fc11.noarch

Comment 3 Bruno Wolff III 2009-04-10 17:48:04 UTC
This got fixed at some point and is no longer an issue in current rawhide.

Comment 4 Tim Jackson 2009-04-14 12:36:44 UTC
Indeed, I checked kernel-2.6.29.1-70.fc11.x86_64.rpm (the -firmware subpackage seems to have been merged with the main package) and it no longer seems to contain any ALSA firmware.

rpm -qpl kernel-2.6.29.1-70.fc11.x86_64.rpm |grep firmware
/lib/modules/2.6.29.1-70.fc11.x86_64/kernel/drivers/firmware
/lib/modules/2.6.29.1-70.fc11.x86_64/kernel/drivers/firmware/dcdbas.ko
/lib/modules/2.6.29.1-70.fc11.x86_64/kernel/drivers/firmware/dell_rbu.ko
/lib/modules/2.6.29.1-70.fc11.x86_64/kernel/drivers/firmware/edd.ko
/lib/modules/2.6.29.1-70.fc11.x86_64/kernel/drivers/firmware/iscsi_ibft.ko
/lib/modules/2.6.29.1-70.fc11.x86_64/kernel/drivers/usb/misc/isight_firmware.ko


Note You need to log in before you can comment on or make changes to this bug.