Bug 487889 - No sound on 82801I / ALC662 - unless this hack is used
No sound on 82801I / ALC662 - unless this hack is used
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-28 16:24 EST by Mads Kiilerich
Modified: 2009-12-02 18:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 18:36:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (34.75 KB, text/plain)
2009-02-28 16:24 EST, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-02-28 16:24:34 EST
Created attachment 333620 [details]
dmesg

Description of problem:

On a friends FUJITSU SIEMENS AMILO Li3710 10601011427 sound didn't work.

Some googling and experiments showed that this in /etc/modprobe.conf made sound work:
options snd-hda-intel model=3stack-dig
options snd-hda-intel single_cmd=1
options snd-hda-intel enable_msi=1

Apparently that causes
ALSA sound/pci/hda/hda_codec.c:2325: hda_codec: model '3stack-dig' is selected
instead of
hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3025:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3029:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3030:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3038:    inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0

I hope you can patch and upstream this hack - or use it as input to find a better solution.

http://www.smolts.org/client/show/pub_5800899e-b719-47c7-a4ac-5e622fd9f2de

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)


Version-Release number of selected component (if applicable):
kernel-2.6.27.15-170.2.24.fc10.i686
Comment 1 Sebastian Krämer 2009-03-30 08:28:54 EDT
Hm, I have an LG notebook with the same sound chip.
Although it didn't work out of the box right after install, it did work just by itself without any further configuration at some point (few hours later, a reboot, don't remember exactly).
Anyway, no special configuration changes to the intel hda kernel module were necessary.
Comment 2 Mads Kiilerich 2009-03-30 09:10:51 EDT
Sebastian, thanks, but I think the sound chip is very common and usually works. Just not on this particular notebook.

It looks like a SND_PCI_QUIRK is needed in alc662_cfg_tbl in sound/pci/hda/patch_realtek.c. I can see that a lot of quirks has been added for 2.6.28 - but it isn't obvious if any of the new ones will solve this problem, and I don't have the system available for testing right now. 

I'm sure it would only take few seconds for a kernel developer to verify/solve this issue ...
Comment 3 Mads Kiilerich 2009-07-24 15:26:06 EDT
Problem remains with Fedora 11 and kernel-PAE-2.6.29.6-213.fc11.i686

Out of the box we get
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64
hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3507: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3511:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3515:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3516:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3524:    inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0

But with /etc/modprobe.d/local.conf 
options snd-hda-intel model=3stack-dig
options snd-hda-intel single_cmd=1
options snd-hda-intel enable_msi=1
we get sound and
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: irq 32 for MSI/MSI-X
HDA Intel 0000:00:1b.0: setting latency timer to 64
ALSA sound/pci/hda/hda_codec.c:2698: hda_codec: model '3stack-dig' is selected
Comment 4 Mads Kiilerich 2009-08-19 18:45:05 EDT
I tested with the latest driver snapshot from alsa-project.org, and it works just fine "out of the box".

Now I am waiting for a Fedora kernel with sufficiently new alsa drivers.
Comment 5 Mads Kiilerich 2009-12-02 18:36:55 EST
The updated driver should be included in the latest kernel versions. Closing.

Note You need to log in before you can comment on or make changes to this bug.