Bug 487927 - Youtube plugin will not play videos
Youtube plugin will not play videos
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-01 09:10 EST by Daniel Berrange
Modified: 2009-04-27 21:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.9.0.10-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 21:20:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-03-01 09:10:11 EST
Description of problem:
I have the totem-youtube extension installed and all available codecs I can find for playing .flv, .mp4 files, etc (tested using youtube-dl to save a film  to local .flv & play in totem).  The totem youtube plugin is able to search for movies & display thumbnails, but double-clicking on any result to play the movie brings up an error dialog. 

"ffdemux_swf: Element doesn't implement handling of this stream. Please file a bug."

On the console I can see a python exception being thrown 

Traceback (most recent call last):
  File "/usr/lib/totem/plugins/youtube/youtube.py", line 174, in on_starting_video
    mrl = "http://www.youtube.com/get_video?video_id=" + urllib.quote (youtube_id) + "&t=" + urllib.quote (re.match (".*[?&]t=([^&]+)", location).groups ()[0])
AttributeError: 'NoneType' object has no attribute 'groups'
** Message: don't know how to handle application/x-shockwave-flash
** Message: Error: Element doesn't implement handling of this stream. Please file a bug.
gstffmpegdemux.c(1440): gst_ffmpegdemux_sink_activate_push (): /play/decodebin2/ffdemux_swf2:
failed to activate sinkpad in pull mode, push mode not implemented yet




Version-Release number of selected component (if applicable):
totem-youtube-2.23.2-10.fc9.i386
totem-gstreamer-2.23.2-10.fc9.i386
gstreamer-0.10.20-1.fc9.i386
gstreamer-ffmpeg-0.10.5-1.fc9.1.i386
gstreamer-plugins-bad-0.10.7-4.fc9.i386
gstreamer-plugins-bad-extras-0.10.7-4.fc9.i386
gstreamer-plugins-base-0.10.19-4.fc9.i386
gstreamer-plugins-base-devel-0.10.19-4.fc9.i386
gstreamer-plugins-farsight-0.12.7-2.fc9.i386
gstreamer-plugins-flumpegdemux-0.10.15-2.fc9.i386
gstreamer-plugins-good-0.10.8-10.fc9.i386
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
gstreamer-plugins-schroedinger-1.0.3-2.fc9.i386
gstreamer-plugins-ugly-0.10.8-2.fc9.i386
gstreamer-python-0.10.11-2.fc9.i386
gstreamer-tools-0.10.20-1.fc9.i386
phonon-backend-gstreamer-4.3.0-5.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Install totem-youtube
2. Do search for 'bfifilms'
3. Double click on first result
  
Actual results:
Error dialog displayed

Expected results:
Video plays

Additional info:
Comment 1 Bastien Nocera 2009-04-24 09:57:38 EDT
The way to parse pages to get the video URL broke a few months back because YouTube changed their pages.

Was fixed in totem 2.24.3
Comment 2 Fedora Update System 2009-04-24 10:38:37 EDT
totem-2.23.2-15.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/totem-2.23.2-15.fc9
Comment 3 Fedora Update System 2009-04-27 16:43:00 EDT
xulrunner-1.9.0.10-1.fc10,firefox-3.0.10-1.fc10,epiphany-2.24.3-6.fc10,epiphany-extensions-2.24.0-8.fc10,blam-1.8.5-10.fc10,devhelp-0.22-8.fc10,galeon-2.0.7-10.fc10,gecko-sharp2-0.13-8.fc10,gnome-python2-extras-2.19.1-30.fc10,gnome-web-photo-0.3-18.fc10,google-gadgets-0.10.5-6.fc10,kazehakase-0.5.6-4.fc10.2,Miro-2.0.3-4.fc10,mozvoikko-0.9.5-10.fc10,mugshot-1.2.2-9.fc10,pcmanx-gtk2-0.3.8-9.fc10,perl-Gtk2-MozEmbed-0.08-6.fc10.1,ruby-gnome2-0.18.1-5.fc10.2,yelp-2.24.0-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xulrunner-1.9.0.10-1.fc10,firefox-3.0.10-1.fc10,epiphany-2.24.3-6.fc10,epiphany-extensions-2.24.0-8.fc10,blam-1.8.5-10.fc10,devhelp-0.22-8.fc10,galeon-2.0.7-10.fc10,gecko-sharp2-0.13-8.fc10,gnome-python2-extras-2.19.1-30.fc10,gnome-web-photo-0.3-18.fc10,google-gadgets-0.10.5-6.fc10,kazehakase-0.5.6-4.fc10.2,Miro-2.0.3-4.fc10,mozvoikko-0.9.5-10.fc10,mugshot-1.2.2-9.fc10,pcmanx-gtk2-0.3.8-9.fc10,perl-Gtk2-MozEmbed-0.08-6.fc10.1,ruby-gnome2-0.18.1-5.fc10.2,yelp-2.24.0-9.fc10
Comment 4 Fedora Update System 2009-04-27 16:43:04 EDT
xulrunner-1.9.0.10-1.fc9,firefox-3.0.10-1.fc9,epiphany-2.22.2-11.fc9,epiphany-extensions-2.22.1-11.fc9,blam-1.8.5-9.fc9.1,chmsee-1.0.1-12.fc9,devhelp-0.19.1-12.fc9,evolution-rss-0.1.0-11.fc9,galeon-2.0.7-10.fc9,gnome-python2-extras-2.19.1-27.fc9,gnome-web-photo-0.3-21.fc9,google-gadgets-0.10.5-6.fc9,gtkmozembedmm-1.4.2.cvs20060817-29.fc9,kazehakase-0.5.6-4.fc9.2,Miro-2.0.3-4.fc9,mozvoikko-0.9.5-10.fc9,mugshot-1.2.2-9.fc9,ruby-gnome2-0.17.0-9.fc9,totem-2.23.2-16.fc9,yelp-2.22.1-12.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xulrunner-1.9.0.10-1.fc9,firefox-3.0.10-1.fc9,epiphany-2.22.2-11.fc9,epiphany-extensions-2.22.1-11.fc9,blam-1.8.5-9.fc9.1,chmsee-1.0.1-12.fc9,devhelp-0.19.1-12.fc9,evolution-rss-0.1.0-11.fc9,galeon-2.0.7-10.fc9,gnome-python2-extras-2.19.1-27.fc9,gnome-web-photo-0.3-21.fc9,google-gadgets-0.10.5-6.fc9,gtkmozembedmm-1.4.2.cvs20060817-29.fc9,kazehakase-0.5.6-4.fc9.2,Miro-2.0.3-4.fc9,mozvoikko-0.9.5-10.fc9,mugshot-1.2.2-9.fc9,ruby-gnome2-0.17.0-9.fc9,totem-2.23.2-16.fc9,yelp-2.22.1-12.fc9
Comment 5 Fedora Update System 2009-04-27 17:36:04 EDT
totem-2.23.2-15.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update totem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4019
Comment 6 Fedora Update System 2009-04-27 21:20:05 EDT
xulrunner-1.9.0.10-1.fc9, firefox-3.0.10-1.fc9, epiphany-2.22.2-11.fc9, epiphany-extensions-2.22.1-11.fc9, blam-1.8.5-9.fc9.1, chmsee-1.0.1-12.fc9, devhelp-0.19.1-12.fc9, evolution-rss-0.1.0-11.fc9, galeon-2.0.7-10.fc9, gnome-python2-extras-2.19.1-27.fc9, gnome-web-photo-0.3-21.fc9, google-gadgets-0.10.5-6.fc9, gtkmozembedmm-1.4.2.cvs20060817-29.fc9, kazehakase-0.5.6-4.fc9.2, Miro-2.0.3-4.fc9, mozvoikko-0.9.5-10.fc9, mugshot-1.2.2-9.fc9, ruby-gnome2-0.17.0-9.fc9, totem-2.23.2-16.fc9, yelp-2.22.1-12.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-04-27 21:21:40 EDT
xulrunner-1.9.0.10-1.fc10, firefox-3.0.10-1.fc10, epiphany-2.24.3-6.fc10, epiphany-extensions-2.24.0-8.fc10, blam-1.8.5-10.fc10, devhelp-0.22-8.fc10, galeon-2.0.7-10.fc10, gecko-sharp2-0.13-8.fc10, gnome-python2-extras-2.19.1-30.fc10, gnome-web-photo-0.3-18.fc10, google-gadgets-0.10.5-6.fc10, kazehakase-0.5.6-4.fc10.2, Miro-2.0.3-4.fc10, mozvoikko-0.9.5-10.fc10, mugshot-1.2.2-9.fc10, pcmanx-gtk2-0.3.8-9.fc10, perl-Gtk2-MozEmbed-0.08-6.fc10.1, ruby-gnome2-0.18.1-5.fc10.2, yelp-2.24.0-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.