Bug 487958 - rpm: setting %_use_internal_dependency_generator 0 causes the rtld(GNU_HASH) requires to be omitted
rpm: setting %_use_internal_dependency_generator 0 causes the rtld(GNU_HASH) ...
Status: CLOSED DUPLICATE of bug 395961
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 487960
  Show dependency treegraph
 
Reported: 2009-03-01 13:58 EST by Chris Weyl
Modified: 2009-03-02 02:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 02:36:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2009-03-01 13:58:35 EST
Description of problem:

Setting %global _use_internal_dependency_generator 0 causes the rtld(GNU_HASH) requires to be omitted... This is not expected.

Version-Release number of selected component (if applicable):
[cweyl@athena scripts]$ rpmquery rpm
rpm-4.6.0-1.fc10.x86_64

I'm reporting this against rawhide, but it is also impacting F-10 at least.

For a rawhide build log, see, e.g.: http://kojipkgs.fedoraproject.org/packages/perl-Readonly-XS/1.05/1.fc11/data/logs/i586/build.log

How reproducible:
Build a binary package, check requires output.  Set %_use_internal_dependency_generator to 0, check requires output.
  
Actual results:
Requires omits 'rtld(GNU_HASH)'.

Expected results:
Requires includes 'rtld(GNU_HASH)'. :-)

Additional info:
The last two revisions of perl-Readonly-XS/devel in CVS are a good example of this.  The second-to-last revision contains no autoreq/prov filtering; the latest sets %_use_internal_dependency_generator to 0 and filters the files entering the _provides_ generator.

My suspicion is that the external find-requires script doesn't know how to deal with rtld(GNU_HASH)...
Comment 1 Jeff Johnson 2009-03-01 20:44:49 EST

Why disable the internal ELF symbol extraction? Any
package produed without the internal dependency generator
that includes ELF binaries is _NOT_ multilib ready.

There are several ways to finesse:
   1) use rpmdeps -R instead of find-requires.
   2) manually add Requires: rtld(GNU_HASH)
   3) Futz about with the hoary find-requires script to emit the dependency.
Comment 2 Panu Matilainen 2009-03-02 02:36:16 EST

*** This bug has been marked as a duplicate of bug 395961 ***

Note You need to log in before you can comment on or make changes to this bug.