This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 487965 - No boot with mdadm 3.x
No boot with mdadm 3.x
Status: CLOSED DUPLICATE of bug 488038
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-03-01 14:54 EST by Nicolas Mailhot
Modified: 2009-03-31 15:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 13:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel logs (64.32 KB, text/plain)
2009-03-01 14:58 EST, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2009-03-01 14:54:34 EST
My /boot is on a raid-1 /dev/md0 device (everything else is lvm-ed over /dev/md1)

Since the mdadm update the boot process fails after the handover from the kernel to init. /boot can not be mounted. When I log-in at the error prompt I always find one of the two pieces of /dev/md0 mounted as /dev/md127 and the other as /dev/md0

Manually stoping /dev/md127 and /dev/md0, then re-assembling /dev/md0 and remounting pretty much everything else permits a successful init 5

Till the next reboot :(
Comment 1 Nicolas Mailhot 2009-03-01 14:58:54 EST
Created attachment 333660 [details]
kernel logs
Comment 2 Sander Hoentjen 2009-03-04 09:19:30 EST
exactly the same here, only i can't seem to start with the newer kernel at all, I still use an f10 kernel
Comment 3 Vlad 2009-03-13 14:19:34 EDT
I have the same proplem, after upgrade f10 to f11 alpha.
Comment 4 Bruno Wolff III 2009-03-15 10:59:41 EDT
As a work around try removing /etc/udev/rules.d/70-mdadm-assemble.rules .
I have been doing that since getting mdadm 3.
This still has problems if a device gets booted out of an array, as udev will try to start separate arrays with the failed devices. If this happens, you can use mdadm to add them back in and reboot.
Comment 5 Doug Ledford 2009-03-18 13:10:43 EDT

*** This bug has been marked as a duplicate of bug 488038 ***
Comment 6 Vlad 2009-03-31 15:16:20 EDT
It seems to fixed for me in bunch of last updates.

Note You need to log in before you can comment on or make changes to this bug.