This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 487966 - Application bug, race in MSG_PEEK
Application bug, race in MSG_PEEK
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-03-01 15:04 EST by Nicolas Mailhot
Modified: 2009-05-11 06:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 10:16:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-03-01 15:04:58 EST
Description of problem:

Found this in kernel logs, no additional info available

kernel: TCP(fetchmail:12072): Application bug, race in MSG_PEEK.

(greping logs for MSG_PEEK reveals lots of older occurrences I didn't notice before)

fetchmail-6.3.9-3.fc11.x86_64
Comment 1 Vitezslav Crhonek 2009-03-02 10:16:18 EST
Hi,

Thanks for report. The log message is present in fetchmail for longer time (I think since Fedora 8). Upstream is aware of this issue and working on fix.

Here you can find additional information:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513695
Comment 2 Vitezslav Crhonek 2009-05-11 06:08:24 EDT
"That's in fact a bug in Linux kernels around the late 2.6.2X versions, rather than fetchmail. Fetchmail has no race bugs around MSG_PEEK, as of version 6.3.9. The message can safely be ignored."
(http://www.fetchmail.info/fetchmail-FAQ.html#O17)

Note You need to log in before you can comment on or make changes to this bug.