Bug 487968 - [PATCH] Support configurable root cache compression
[PATCH] Support configurable root cache compression
Status: CLOSED CURRENTRELEASE
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-01 16:41 EST by Lubomir Rintel
Modified: 2013-01-10 00:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-11 14:43:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Support configurable root cache compression (4.08 KB, patch)
2009-03-01 16:41 EST, Lubomir Rintel
no flags Details | Diff

  None (edit)
Description Lubomir Rintel 2009-03-01 16:41:02 EST
Created attachment 333665 [details]
Support configurable root cache compression

This patch adds configuration options that influence how is the root
cache compressed:

  config_opts['plugin_conf']['root_cache_opts']['compress_program'] = "gzip"
  config_opts['plugin_conf']['root_cache_opts']['extension'] = ".gz"

Motivation to do this was to be able to use lzma compression. While it
takes a long time to compress, for me it was more than two times faster
than gzip when decompressing. Since I only seldom regenerate the root cache
while doing a lot of builds, I was able to gain a considerable speed up.
Comment 1 Lubomir Rintel 2009-03-20 06:35:22 EDT
Ping?
Comment 2 Clark Williams 2009-03-27 11:24:14 EDT
Looks fine. I've pulled it in for inclusion in the next release.
Comment 3 Clark Williams 2010-09-11 14:43:31 EDT
I missed closing this when the change went in.

Note You need to log in before you can comment on or make changes to this bug.