Bug 488023 - Update to 1.0.0 for bt and usb sniffing capability
Update to 1.0.0 for bt and usb sniffing capability
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libpcap (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
http://www.tcpdump.org/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 03:39 EST by Juha Tuomala
Modified: 2009-07-24 06:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 06:27:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2009-03-02 03:39:09 EST
Description of problem:

http://wiki.wireshark.org/Bluetooth
> The Bluetooth stack is partially implemented and Wireshark can 
> dissect several of the layers and protocols of the stack. 
> There is a libpcap format defined for Bluetooth frames, and 
> support in libpcap 1.0.0 and later for capturing on Bluetooth 
> devices in Linux; Wireshark, if linked with that version of libpcap, 
> is able to capture on Bluetooth devices. (In Linux distributions 
> that come with pre-1.0.0 versions of libpcap, libpcap doesn't support
> capturing on Bluetooth devices, so you would have to get libpcap 1.0.0
> or later from tcpdump.org, install it, and build Wireshark with that 
> version of libpcap in order to capture on Bluetooth devices. 
>
> As of 2009-01-27, Gentoo Linux has libpcap with Bluetooth support in 
> its mainline repository (portage).) Wireshark can also read captures 
> in that format.

So, in order to sniff bt, we need this. It's very useful when 
developing mobile phone syncing tools, which in other hand is 
major problem in OSS desktop software these days.

Version-Release number of selected component (if applicable):
libpcap-0.9.8-3.fc10.x86_64


Additional info:
http://www.tcpdump.org/#latest
http://www.tcpdump.org/release/libpcap-1.0.0.tar.gz
http://www.tcpdump.org/libpcap-changes.txt
http://www.tcpdump.org/release/libpcap-1.0.0.tar.gz.sig
Comment 1 Miroslav Lichvar 2009-03-02 09:04:51 EST
I'm waiting for 1.0.1, because there are some regressions in 1.0.0.

Maybe we could update to a git snapshot.
Comment 2 Juha Tuomala 2009-03-02 09:24:43 EST
Yeah, if that doesn't cause any trouble. tcpdump folks don't hang in freenode?
Comment 3 Miroslav Lichvar 2009-03-02 10:59:15 EST
This will require rebuild of ~80 packages. I'm afraid it's too late for F11, the beta freeze is just in few days.
Comment 4 Juha Tuomala 2009-03-02 11:49:09 EST
How did you come up with 80 pkgs? My desktop has only ppp that directly --requires it and if the requirement is something non-linking, is there really incompatibilities in such update?
Comment 5 Juha Tuomala 2009-03-02 12:06:00 EST
> 2009-05-26   Fedora 11 Final Release 

would mean that rawhide opens next time at July.
Comment 6 Miroslav Lichvar 2009-03-02 12:08:14 EST
yum-utils package has repoquery tool.

$ repoquery --repoid=rawhide --whatrequires 'libpcap.so.0.9()(64bit)' | wc -l
78
Comment 7 Juha Tuomala 2009-03-02 12:14:39 EST
Yeah. Have to reinvent the wheel and package it locally.
Comment 8 Miroslav Lichvar 2009-07-24 06:27:13 EDT
libpcap in rawhide was updated to libpcap-1.0.0-1.20090716git6de2de.fc12.

Note You need to log in before you can comment on or make changes to this bug.