This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488066 - Thunderbird locks CPU in 100% with Lightning and SSL
Thunderbird locks CPU in 100% with Lightning and SSL
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: thunderbird (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Jan Horak
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 08:17 EST by Mauricio Teixeira
Modified: 2012-04-12 10:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 10:45:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 390036 None None None Never

  None (edit)
Description Mauricio Teixeira 2009-03-02 08:17:11 EST
thunderbird-2.0.0.19-1.el5_2
Lightning 0.9 (xpi from Mozilla's plugin site)

Thunderbird locks CPU in 100% when you have Lightning calendar plugin installed. This happens specifically when you have both IMAP+SSL and CalDAV+SSL (or iCal+SSL).

According to a few comments in Lightning bugzilla (https://bugzilla.mozilla.org/show_bug.cgi?id=390036#c71 and after), the bug seems to be with Thunderbird, which holds one single thread for all SSL communications.

Long story short, when you use IMAP+SSL Thunderbird acquires a lock on the SSL thread, while at the same time Lightning tries loops into a flag waiting for it to be released. If this happens on first opening of Thunderbird, the thread will never be unlocked, and CPU will lock in 100% usage from Thunderbird process.

Workaround is to use either calendars or IMAP without SSL, even though both solutions are rather insecure.

Still according to the mentioned bugzilla (https://bugzilla.mozilla.org/show_bug.cgi?id=390036#c81) a patch is being worked on, but nothing has been released.

This bug also affects both Thunderbird 3.0pre and Lightning 1.0pre
Comment 3 Kai Engert (:kaie) 2009-03-05 11:41:35 EST
Mauricio, are you really able to reproduce this bug with latest Thunderbird 3 pre-release (Shredder) and latest Lightning pre-release code?

If you do, you are the first who can reproduce in that combination.
If you do, can you please provide details of your configuration?
Comment 4 Mauricio Teixeira 2009-03-09 17:04:26 EDT
Sorry, I haven't have time to install beta releases of Thunderbird to try. I had a colleague trying it, so I'll ask him to comment.
Comment 5 collura 2011-07-21 02:38:27 EDT
still occurs with:

thunderbird-3.1.11-1.fc14 (x86_64)
thunderbird-lightning-1.0-0.41.b3pre.fc14 (x86_64)
xorg-x11-server-Xorg-1.9.5-1.fc14 (x86_64)
metacity-2.30.3-2.fc14 (x86_64)
xulrunner-1.9.2.18-1.fc14 (x86_64)
Comment 6 RHEL Product and Program Management 2012-01-09 08:53:32 EST
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.8 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 8 Jan Horak 2012-03-22 10:45:37 EDT
Upstream bug was closed as WORKSFORME, reopen when problem reoccurs.

Note You need to log in before you can comment on or make changes to this bug.