Bug 488076 - cannot package even simplest maven project
cannot package even simplest maven project
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: maven2 (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 10:01 EST by Christoph Höger
Modified: 2009-03-02 11:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 11:51:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mvn package run (5.84 KB, application/octet-stream)
2009-03-02 10:01 EST, Christoph Höger
no flags Details
automagically generated pom.xml (642 bytes, text/xml)
2009-03-02 11:00 EST, Christoph Höger
no flags Details

  None (edit)
Description Christoph Höger 2009-03-02 10:01:37 EST
Created attachment 333749 [details]
mvn package run

Description of problem:
I am currently trying to migrate some projects to maven. I cannot package even the simplest my-app example. Due to the following reason:

[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] The plugin 'org.apache.maven.plugins:maven-surefire-plugin' does not exist or no valid version could be found
[INFO] ------------------------------------------------------------------------


Version-Release number of selected component (if applicable):
maven2-2.0.4-10jpp.10.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. mvn archetype:create -DgroupId=com.mycompany.app -DartifactId=my-app
2. mvn package
  
Actual results:
see attached log

Expected results:
a simple .jar file should be packaged and tested

Additional info:
pom.xml is completely auto generated

[root@choeger6 modprobe.d]# rpm -qa | grep surefire
maven-surefire-booter-1.5.3-2jpp.5.fc9.i386
maven-surefire-1.5.3-2jpp.5.fc9.i386
maven2-plugin-surefire-2.0.4-10jpp.10.fc9.i386
maven2-plugin-surefire-report-2.0.4-10jpp.10.fc9.i386
Comment 1 Deepak Bhole 2009-03-02 10:40:37 EST
Can you attach the pom file you are using?
Comment 2 Christoph Höger 2009-03-02 11:00:47 EST
Created attachment 333753 [details]
automagically generated pom.xml

As I said, that pom file did not get _any_ change from me (did not have a chance to wreck it by myself ;) )
Comment 3 Deepak Bhole 2009-03-02 11:17:51 EST
But how do I reproduce this then? Because maven is working for me for simpler projects that I tried..
Comment 4 Christoph Höger 2009-03-02 11:30:27 EST
So the steps above (creating sample app and packaging) work for you? 
Any chance I can figure out what's screwed up on my machine?
Comment 5 Christoph Höger 2009-03-02 11:35:16 EST
OK, that's weird, I just moved away ~/.m2 and now things work fine.
If anyone is interested in investigating that issue I can attach a zipped version of my old .m2 dir (or any particular file therein).
Comment 6 Deepak Bhole 2009-03-02 11:51:38 EST
Ah, cool, good to know it is working again. Had you ever used mvn-jpp via command-line? That could cause an issue like this. If not that, then it sounds like some sort of upstream issue..

Note You need to log in before you can comment on or make changes to this bug.