Bug 488078 - Missing dependencies listed in gupnp-1.0.pc
Summary: Missing dependencies listed in gupnp-1.0.pc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gupnp
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-02 15:10 UTC by Michel Alexandre Salim
Modified: 2009-03-03 10:45 UTC (History)
1 user (show)

Fixed In Version: gupnp-0.12.6-3.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-03 10:45:29 UTC
Type: ---


Attachments (Terms of Use)

Description Michel Alexandre Salim 2009-03-02 15:10:06 UTC
Description of problem:
gupnp-1.0.pc lists the following dependencies that are not pulled in when installing gupnp-devel:

Requires:
libxml2-devel
libsoup-devel

Requires.Private:
uuid-devel
glib2-devel


Version-Release number of selected component (if applicable):
gupnp-devel-0.12.5-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install gupnp-devel on a system w/o development libraries
2. pkg-config --libs gupnp-1.0

  
Actual results:
pkg-config lists the missing libraries

Expected results:
This should work

Additional info:

Comment 1 Peter Robinson 2009-03-02 16:57:52 UTC
Hmm. I thought RPM picked those deps up. I'll add them now and push a fix out. The uuid package required is actually e2fsprogs-devel as that's the uuid package that it uses (why its in ext filesystem utils progs I have no idea :-) )

Comment 2 Peter Robinson 2009-03-02 17:54:27 UTC
Can you verify that the build I've just pushed fixes this issue (will be in rawhide shortly).

http://koji.fedoraproject.org/koji/taskinfo?taskID=1213984

Comment 3 Michel Alexandre Salim 2009-03-02 18:20:22 UTC
That works, thanks. Didn't realize that uuid-devel actually installs ossp-uuid, not uuid.

I don't think rpm automatically resolves dependencies stated in .pc files. Too bad, really. A lot of packages are breaking now because the new pkgconfig also exposes Requires.Private, instead of just Requires, it'd have been nice to have more automation.

Comment 4 Peter Robinson 2009-03-02 22:30:52 UTC
Hmm. Looks like I need to go and review my other packages too to see what else is affected!

Comment 5 Peter Robinson 2009-03-03 10:45:29 UTC
Fixed in rawhide. The change is also in F-10 packages but I'll push it out on the next update to save on updates.


Note You need to log in before you can comment on or make changes to this bug.