This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488158 - yum fails with "TypeError: 'NoneType' object is not iterable"
yum fails with "TypeError: 'NoneType' object is not iterable"
Status: CLOSED DUPLICATE of bug 487774
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 17:24 EST by Michal Jaegermann
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 09:53:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-03-02 17:24:16 EST
Description of problem:

An attempt of

  yum localupdate vte-0.19.4-5.fc11.x86_64.rpm

fails with the message as in summary and a traceback.  Adding debug flags does not bring much more but this is what you can see:
...
Resolving Dependencies
--> Running transaction check
---> Package vte.x86_64 0:0.19.4-5.fc11 set to be updated
Checking deps for vte.x86_64 0-0.19.4-5.fc11 - u
Checking deps for vte.x86_64 0-0.19.4-3.fc11 - None
--> Finished Dependency Resolution
Dependency Process ending
Depsolve time: 3.220

Dependencies Resolved
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 301, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 253, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 363, in doTransaction
    lsts = self.listTransaction()
  File "/usr/share/yum-cli/output.py", line 929, in listTransaction
    a_wid = _add_line(lines, data, a_wid, txmbr.po, txmbr.obsoletes)
  File "/usr/share/yum-cli/output.py", line 907, in _add_line
    elif po.verifyLocalPkg():
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 664, in verifyLocalPkg
    (csum_type, csum) = self.returnIdSum()
TypeError: 'NoneType' object is not iterable


Version-Release number of selected component (if applicable):
yum-3.2.21-11.fc11

How reproducible:
on every try

Additional info:
No issues with 'rpm -Fvh vte-0.19.4-5.fc11.x86_64.rpm'.  'yum update' does install a broken vte-0.19.4-4.fc11 without any issues and no other update packages seem to be available on mirrors at this moment.
Comment 1 James Antill 2009-03-03 09:53:29 EST

*** This bug has been marked as a duplicate of bug 487774 ***

Note You need to log in before you can comment on or make changes to this bug.