Bug 488172 - Package Review: ibus-table-zhengma
Package Review: ibus-table-zhengma
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
: i18n
Depends On: 488010
Blocks: 484650
  Show dependency treegraph
 
Reported: 2009-03-02 19:03 EST by Caius Chance
Modified: 2009-04-07 01:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 23:47:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review-


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2009-03-02 19:03:30 EST
A split from ibus-table-chinese, which was sub-package of ibus-table.

Uploading srpm and spec.
Comment 1 Caius Chance 2009-04-01 22:47:49 EDT
SRPM URL:
http://cchance.fedorapeople.org/packaging/ibus-table-zhengma-1.1.0.20090402-1.fc11.src.rpm
Spec URL: http://cchance.fedorapeople.org/packaging/ibus-table-zhengma.spec
Description: A split from ibus-table-chinese, which was sub-package of ibus-table.
Comment 2 Parag AN(पराग) 2009-04-03 01:43:11 EDT
Review:
+ package builds in mock (rawhide i586).
koji build => http://koji.fedoraproject.org/koji/taskinfo?taskID=1274694
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
5981da2341988d13ebd0c6c01bcb047f  ibus-table-zhengma-1.1.0.20090402.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ BuildRequires are proper.
+ defattr usage is correct.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ ibus-table-createdb scriptlet used.
+ file permissions are appropriate.
+ Not a GUI App.  

Suggestions:
1) check header of zhengma.txt table file. Can you confirm license with upstream if it really is GPLv3+?
2) try adding contents to Changelog file in upstream and add it as %doc
Comment 4 Parag AN(पराग) 2009-04-06 23:47:40 EDT
Looks like patent problem here.
Comment 5 Caius Chance 2009-04-07 01:37:22 EDT
Patent should be expired in DEC 09.

Note You need to log in before you can comment on or make changes to this bug.