Bug 488180 - the admin server still prompts for the directory manager password after adding a new instance and running register-ds-admin.pl
the admin server still prompts for the directory manager password after addin...
Status: CLOSED DUPLICATE of bug 486402
Product: 389
Classification: Community
Component: Command Line Utilities (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
Depends On:
  Show dependency treegraph
Reported: 2009-03-02 20:04 EST by Brian J. Atkisson
Modified: 2015-01-04 18:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-03 16:24:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian J. Atkisson 2009-03-02 20:04:34 EST
Description of problem:

I built out a new RHDS 8 master using setup-ds-admin.pl.  That instance works fine when using the IDM console and I do not get prompted for a directory manager password.  Then I added a second instance on a different port using setup-ds.pl.  I used register-ds-admin.pl in interactive mode and ran through all the options.  register-ds-admin.pl registered the new instance with the admin server.  However, whenever I access this new instance via the IDM console, I am prompted for the directory manager password.  I correctly provided this information when running register-ds-admin.pl.

Version-Release number of selected component (if applicable): redhat-ds-admin-8.0.4-3.el5dsrv

How reproducible: every time, I've tried multiple times

Steps to Reproduce:
1. install a new master with setup-ds-admin.pl (with a local admin server)
2. install another instance with setup-ds.pl
3. run register-ds-admin.pl and provide all the requested information
4. setup-ds-.pl and register-ds-admin.pl will both complete successfully
5. log in with admin user in the IDM console
6. open the new instance, you will be prompted for the directory manager password.
Actual results:
prompted for the directory manager password

Expected results:
The new instance should open in the IDM console without prompting for a password.

Additional info: this may be related to https://bugzilla.redhat.com/show_bug.cgi?id=488179.
Comment 1 Nathan Kinder 2009-03-03 16:24:59 EST
I believe that this is taken care of by my recent fix for bug 486402.

The problem was that the register-ds-admin.pl script was not setting the pass-through authentication plug-in, which is used to let the admin user authenticate to the non-config DS instances.

*** This bug has been marked as a duplicate of bug 486402 ***

Note You need to log in before you can comment on or make changes to this bug.