Bug 488183 - mkinitrd fails with: "cp: cannot stat `/usr/lib64//libparted-1.8.so.8.0.0': No such file or directory"
mkinitrd fails with: "cp: cannot stat `/usr/lib64//libparted-1.8.so.8.0.0': N...
Status: CLOSED DUPLICATE of bug 502221
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 21:21 EST by John Ellson
Modified: 2009-05-25 04:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 04:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2009-03-02 21:21:53 EST
Description of problem:
mkinitrd fails with: "cp: cannot stat `/usr/lib64//libparted-1.8.so.8.0.0': No such file or directory"

Probably because this file doesn't exist since parted moved stuff around.  Perhaps it should be looking for: /lib64/libparted-1.8.so.8.0.0

Version-Release number of selected component (if applicable):
mkinitrd-6.0.78-2.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1. mkinitrd /boot/initrd-2.6.29-0.179.rc6.git5.fc11.x86_64.img 2.6.29-0.179.rc6.git5.fc11.x86_64
2.
3.
  
Actual results:
cp: cannot stat `/usr/lib64//libparted-1.8.so.8.0.0': No such file or directory

Expected results:


Additional info:
The installed kernel panics during boot.  I haven't checked yet, but it could be for the same reason.
Comment 1 Hans de Goede 2009-03-03 04:07:28 EST
Can you do "ls -l /usr/lib64/libparted*" please and paste the output here? I think you've got a dangling libparted-1.8.so.8 symlink under there.
Comment 2 John Ellson 2009-03-03 16:53:58 EST
root@ontap:~# yum reinstall parted
...
Removed:
  parted.x86_64 0:1.8.8-14.fc11                                                 

Installed:
  parted.x86_64 0:1.8.8-14.fc11                                                 

Complete!
root@ontap:~# ls /usr/lib*/libpart* /lib*/libpart*
/lib64/libparted-1.8.so.8      /usr/lib64/libparted-1.8.so.8
/lib64/libparted-1.8.so.8.0.0  /usr/lib64/libparted.so
root@ontap:~#
Comment 3 John Ellson 2009-03-03 17:01:50 EST
sorry, that was supposed to be ls -l...

the two in /usr/lib64 were softlinks, but not dangling


I just did:

# rm /usr/lib*/libpart* /lib*/libpart*
# yum reinstall parted

now the links in /usr/lib64/ are gone.

Looks like parted rpm isn't cleaning up properly.


mkinitrd seems happier now ...   rebooting ....
Comment 4 Hans de Goede 2009-03-08 06:06:50 EDT
Ok, I think you've hit some packaging bug in parted, closing as not a bug (because it is not an mkinitrd bug).
Comment 5 Hans de Goede 2009-05-25 04:23:58 EDT
Ok, so I can reproduce this now, and this is a real issue, re-opening and
then closing as a dup of the bug were this will be tracked, please see that
bug for more details and add yourself to the CC if you want to kept up2date.
Comment 6 Hans de Goede 2009-05-25 04:24:24 EDT

*** This bug has been marked as a duplicate of bug 502221 ***

Note You need to log in before you can comment on or make changes to this bug.