Bug 488207 - gpk-update-viewer: checkboxes to in/exclude updates force row selection, metadata query
gpk-update-viewer: checkboxes to in/exclude updates force row selection, meta...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 03:12 EST by "FeRD" (Frank Dana)
Modified: 2009-06-03 05:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 05:23:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description "FeRD" (Frank Dana) 2009-03-03 03:12:12 EST
Description of problem:
When viewing a list of updates in gpk-update-viewer, individual updates can be enabled or disabled via a checkbox in the left column of each row. Toggling this checkbox also selects the row in question, forcing unwanted/unnecessary/unspeedy retrieval of update details and resultant load on the package-management backend.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.14-1.fc10.x86_64

How reproducible:
Deselect update from detail listing view in gpk-update-viewer.

Steps to Reproduce:
1. Start gpk-update-viewer on a system which has at least 1 update pending
2. Click "Review" to display the list of pending updates
3. Wait for retrieval of the details for the first update in the list
4. Uncheck the box for any other update listed, for instance "whizzo-butter-0.1-1:42.mc68k

  
Actual results:
The 'whizzo-butter' update is excluded (checkbox toggled), as expected. However, focus for the list is also moved to the 'whizzo-butter' entry, resulting in a non-trivial request being fired off to the package-management backend for the details of the (now-excluded) 'whizzo-butter' update.

Expected results:
gpk-update-viewer might assume I'm clueful enough that if I'm excluding an update, I must already KNOW what it is, and don't need to be kept waiting while it finds out what I already know and shows it to me. In other words, toggling a checkbox shouldn't be tied to selecting its row. This seems a trivial UI niggle, and WOULD be, except row-selection is the trigger for that highly resource-intensive metadata query. (This is especially problematic on "older" systems, like my P4/2.4GHz server. It takes on the order of several seconds to pull details when I select a row. All this waiting quickly adds up. Especially when holding a package back and having to uncheck it each and every update run, as I've been doing with 'whizzo-butter'*.)

Additional info:
This is technically a duplicate of bug 439454, which is marked as closed. However, that bug got a bit muddied with some different, closely-related issues that came up. One such issue was fixed, and resulted in the bug being closed. However, THIS checkbox issue, which is the same as originally reported in 439454's summary, has NOT been fixed. (As of F10's current 0.3.14-1 build of gpk.)

* - In the case of my P4 box, 'whizzo-butter' represents xorg-x11-drv-i810, which I've been holding down to the last F9 release (2.3.2, from November) that allowed me to successfully boot the crap Sony desktop in question. The current F10 package, 2.5.0-4, is from December 2. Thus, the total time spent retrieving update info that I've seen over and over again is not only significant, it's... frustrating. PackageKit isn't the source of the frustration, it's just unwittingly rubbing salt in the wound.
Comment 1 Richard Hughes 2009-04-15 12:42:25 EDT
Should be fixed in rawhide, right?
Comment 2 "FeRD" (Frank Dana) 2009-04-18 00:17:58 EDT
I'll take a look...

Nerds. Both of my boxes are still tracking F10+updates, and a quick try at installing rawhide's gnome-packagekit sucked in updates to the entire universe as collateral damage.

I'll grab the source RPMs for rawhide's PackageKit bits and see if I can get them to build in an F10 environment; if so I'll test it out -- otherwise, I won't be able to confirm until a newer PackageKit hits F10, or F11 is farther along in its pre-release cycle.
Comment 3 "FeRD" (Frank Dana) 2009-04-18 00:26:14 EDT
Bleah. No-go, way too many post-F10 build dependencies to shoehorn rawhide's gnome-packagekit into my boxes. :(

Note You need to log in before you can comment on or make changes to this bug.