Bug 48822 - Redhat 7.1 ships with a bad version of aic7xxx driver
Redhat 7.1 ships with a bad version of aic7xxx driver
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 18:09 EDT by IBM Bug Proxy
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 13:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2001-07-11 18:09:11 EDT
Description of Problem:
Hardware Environment:
Adaptec SCSI Host Bus Adapter
Software Environment:
Any



How Reproducible:


Steps to Reproduce:
1. Transfer odd byte (read or write)
2. Attach Magstar 3590 or IBM 3584
 
 

Actual Results:
1. Adaptec driver unable to handle odd byte transfer
2. Adaptec driver unable to claim LUN 1 devices



Expected Results:
 allow odd byte transfer and lun 1 device attachment



Additional Information:
	
Kernel 2.4.2 had version 5.2.1 for aic7xxx and it worked.
Kernel 2.4.5 had version 6.1.13 for aic7xxx and it fixes the problem as
well.
We need to know when would redhat release another version that would
address this problem
Comment 1 Arjan van de Ven 2001-07-11 18:14:50 EDT
Does the 6.1.11 version in the 2.4.3-12 kernel work ?
Comment 2 Doug Ledford 2001-08-02 13:46:52 EDT
Putting two bugs into the same report makes it hard to close a report out as one
bug is fixed/diagnosed.  They should always be kept separate.

However, to address the two issues:

1) Fails on odd byte transfers.

I need exact error messages and I need to know what the OS did in this case.  To
my knowledge, the only way Linux will ever request the transfer of an odd byte
count is during the INQUIRY command, so it's not something that should be seen
under normal use, but instead only once at startup or some such.

2) Can't attach LUN 1 devices.

What are you comparing this to?  Custom built kernels or other Red Hat kernels? 
Have you considered that in Red Hat kernels we do not (and *NEVER* will) enable
the PROBE_ALL_LUNS option?  Have you tried an 'echo "scsi-add-single-device a b
c d" > /proc/scsi/scsi' command (replacing a with the host number, b with the
channel number, c with the device ID, and d with the LUN number) to see if the
device is found then?  If it is, then there is no bug here, it is expected
behaviour.  If not, then I need to know the particulars of the device and I
would need a trace of the driver attempting to locate the LUN 1 device before I
could do anything more.
Comment 3 Need Real Name 2001-10-03 17:53:50 EDT
Note from the submitter states: Got the following info from the bug submitter:
-----------------------------------------------------------------------------
Sorry for not replying sooner.  Yes, we have found a work round.  It would 
appeared that Red Hat 7.1 ships with a newer version of the aic7xxx driver 
(named aic7xxx_mod), and that driver is working much better.  We did get hold of 
Arjan, and that information came from him.
--------------------------------------------------------------------------------
OK to close this bug. 

Note You need to log in before you can comment on or make changes to this bug.