Bug 488246 - Activation of RHN Proxy for second time will fail
Activation of RHN Proxy for second time will fail
Status: CLOSED DUPLICATE of bug 501508
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Network Quality Assurance
us=79015
:
Depends On:
Blocks: 428922
  Show dependency treegraph
 
Reported: 2009-03-03 09:14 EST by Miroslav Suchý
Modified: 2013-01-10 04:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 17:00:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-03-03 09:14:30 EST
Description of problem:
See steps to reproduce

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
0. rhn_register to hosted (I done against webqa)
1. install pacewalk-proxy-installer from RHN tools channel
2. run configure-proxy.sh
3. Let it fail (e.g. put wrong password to SSL cert)
4. installer will deactivate the proxy
5. run configure-proxy.sh again
And during activation you will get error
  
Actual results:
....
Organization []: RedHat
Organization Unit [vmware127.englab.brq.redhat.com]:
Common Name [vmware127.englab.brq.redhat.com]:
City []: brno
State []: .
Country code []: CZ
Email [msuchy@redhat.com]:
API version: 5.0.9

There was a problem activating the RHN Proxy entitlement:
ERROR: upon entitlement/activation attempt: unknown error - <Fault -2: 'unhandled internal exception: null'>
Proxy activation failed! Installation interrupted.
API version: 5.0.9
RHN Proxy successfully deactivated.

Expected results:
No errors and successfully activate even for second time activation.

Additional info:
Comment 1 Stephen Herr 2009-07-23 17:00:08 EDT
While it may not look like a duplicate, this issue was resolved by the fix for bug 501508.

*** This bug has been marked as a duplicate of bug 501508 ***

Note You need to log in before you can comment on or make changes to this bug.