This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 48825 - "rpm -e --nodeps" ignoring --nodeps
"rpm -e --nodeps" ignoring --nodeps
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 19:39 EDT by Panic
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 12:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panic 2001-07-11 19:39:44 EDT
Description of Problem: In qa0711.0, the "--nodeps" option for "rpm -e"
does not appear to work.  The output is the same as if the option was not
there.  

How Reproducible:

Always

Steps to Reproduce:
1. attempt to remove a package, say the zip package, with this command:

rpm -e --nodeps zip

2. 

Output looks like this:

error: removing these packages would break dependencies
     zip is needed by kdeutils-2.1.1-4
     zip >= 2.1 is needed by libgcj-3.0-3
     zip >= 2.1 is needed by libgcj-devel-3.0-3

which is the same as the output when --nodeps is NOT specified on the
command line.

3. 

Actual Results:

RPM is not removed.


Expected Results:

RPM should be removed, with no error messages.

Additional Information:

Untested with rpm -i, -U, and -F.

There is also a noticeable pause between the completion of the command and
the return to the command prompt -- could be my system being slow
(P233/80MB laptop).
Comment 1 Jeff Johnson 2001-07-12 07:07:18 EDT
This has always been the behavior of --nodeps and --erase, so not a bug.

The slowness is due to verifying data integrity on close if opened R/W, new
behavior in rpm-4.0.3
Comment 2 Panic 2001-07-12 11:26:47 EDT
Looking at what I wrote, I wasn't clear.  I will reiterate, with additional
information:  the option --nodeps does not function in any of the following
cases (test case was installing wvdial without the PPP package installed):


rpm -Uvh --nodeps wvdial-1.41-13.i386.rpm
rpm -ivh --nodeps wvdial-1.41-13.i386.rpm

In both cases, the package refused to install due to dependency errors (the PPP
package).  The expected case is that the package will be installed regardless of
dependencies, and functions exactly as expected on a 7.1 system.  The --nodeps
option also fails to function when trying to remove a package with this command:

rpm -e --nodeps zip

The result is that the package is not removed, and there is a dependency error
returned even though I specified the --nodeps option.  Does this make more sense?
Comment 3 Jeff Johnson 2001-07-12 12:26:17 EDT
Is this rpm-4.0.3-0.66 or later? If earlier, then there was known CLI
breakage there. Otherwise, please try (read: the CLI was very broken)
rpm-4.0.3-0.66 or later.
Comment 4 Panic 2001-07-12 12:43:27 EDT
It was the 4.0.3-0.66 version.  I tried 4.0.3-0.68 from 7.2-HEAD, same symptoms.
Comment 5 Panic 2001-07-12 16:21:45 EDT
Thanks Jeff.  Works like a charm.

Note You need to log in before you can comment on or make changes to this bug.