This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488259 - grub does not want to boot after yum update. Shows "GRUB" in the top left corner.
grub does not want to boot after yum update. Shows "GRUB" in the top left co...
Status: CLOSED DUPLICATE of bug 450143
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 10:32 EST by Rick Richardson
Modified: 2009-05-29 11:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 11:31:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Richardson 2009-03-03 10:32:18 EST
FYI:

Did my weekly "yum update".  This time:

> [rick@kathleen ~]# yum update
> {snip}
> kernel.i686 0:2.6.27.19-170.2.35.fc10
> {snip}
> Complete!
> [rick@kathleen ~]# init 6
>
> Did not come up;  When I went to check on it, it says:
>
> GRUB
>
> In the top left corner...   Thats it...

Booted CD, selected Rescue Disk, then

# chroot /mnt/sysimage
# grub-install /dev/sda

Reboot.
Everything is normal again.
Comment 1 Rick Richardson 2009-03-03 11:57:34 EST
On Tuesday (03/03/2009 at 09:20AM -0600), Rick Richardson wrote:
> On Tue, Mar 03, 2009 at 09:07:00AM -0600, Rick Richardson wrote:
> >
> > [rick@kathleen ~]$ root yum update
> > {snip}
> > kernel.i686 0:2.6.27.19-170.2.35.fc10
> > {snip}
> > Complete!
> > [rick@kathleen ~]$ root init 6
> >
> > Did not come up;  When I went to check on it, it says:
> >
> > GRUB
> >
> > In the top left corner...   Thats it...
>
> Booted CD, selected Rescue Disk, then
>
> # chroot /mnt/sysimage
> # grub-install /dev/sda
>
> Reboot.
> Everything is normal again.

I had to do the EXACT same thing on a laptop I updated on Sunday.  But other
platforms I have updated at the same time had no such issue.

chris
Comment 2 Rick Richardson 2009-03-04 10:20:38 EST
> On Tuesday (03/03/2009 at 11:01AM -0600), Rick Richardson wrote:
> > # yum update
> > # grub-install /dev/sda
> > # init 6

I did this on rick-laptop today.  No problem and I didn't have to boot the rescue CD like for kathleen's desktop yesterday.  Don't know why grub-install isn't getting called or is buggy on some desktops or laptops.
Comment 3 Michael Schwendt 2009-05-29 11:31:39 EDT

*** This bug has been marked as a duplicate of bug 450143 ***

Note You need to log in before you can comment on or make changes to this bug.