Bug 488289 - [Intel 5.4 FEAT] Update wireless iwl3945 uCode
[Intel 5.4 FEAT] Update wireless iwl3945 uCode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iwl3945-firmware (Show other bugs)
5.4
All Linux
high Severity high
: rc
: ---
Assigned To: John W. Linville
desktop-bugs@redhat.com
http://intellinuxwireless.org/?n=Down...
:
Depends On: 476869
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 11:42 EST by John W. Linville
Modified: 2009-09-02 05:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 476869
Environment:
Last Closed: 2009-09-02 05:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John W. Linville 2009-03-03 11:42:56 EST
+++ This bug was initially created as a clone of Bug #476869 +++

Update the micro-code (aka firmware) for the iwl4965 wireless card.

One difficult issue made it to the top 10 kerneloops.org which resulted in releasing a new version of the 4965 uCode to fix it.

Q: should OSVs pick up the new version of 4965 uCode?

[Majid ] yes indeed

Arjan tells me that it is very important to get resolving lots of issue reports.

[Majid ] there is a long nasty difficult bug took a long time to resolve, and it ended up to be  in the uCode.  This new uCode fixes the kernel oops – even thought it’s hard to reproduce it.

Q: what has to go along with it?  new driver?  the new driver would include support for 3 drivers?  would this mean new uCode for 3945 and 5000 would also be needed?

[Majid ] no, it’s the same driver, even the driver in 2.6.27 was impacted.

--- Additional comment from jvillalo@redhat.com on 2008-12-17 11:44:49 EDT ---

Microcode can be downloaded from:
http://intellinuxwireless.org/?n=Downloads

--- Additional comment from jvillalo@redhat.com on 2008-12-17 11:51:37 EDT ---

Created an attachment (id=327268)
Latest iwl4965 microcode as of 17-Dec-2008
Comment 5 DongpoLiu 2009-04-14 22:19:42 EDT
It seems the latest iwl3945 uCode (version No.iwlwifi-3945-ucode-15.28.2.8) is imcompitable with kernel-2.6.18-138.el5.jwltest.x86_64 under RHEL 5.3 RC2 OS, we get following message from dmesg:
Apr  9 16:22:06 osve-sr kernel: PCI: Enabling device 0000:01:00.0 (0000 -> 0002) 
Apr  9 16:22:06 osve-sr kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 177
Apr  9 16:22:06 osve-sr kernel: iwl3945: iwlwifi-3945-1.ucode firmware file req failed: Reason -2
Apr  9 16:22:06 osve-sr kernel: iwl3945: Could not read microcode: -2 
Apr  9 16:22:06 osve-sr kernel: ACPI: PCI interrupt for device 0000:01:00.0 disabled 
Apr  9 16:22:06 osve-sr firmware_helper[3793]: Loading of /lib/firmware/iwlwifi-3945-1.ucode for iwl3945 driver failed: No such file or directory.

To enable the latest iwl3945 uCode (version No.iwlwifi-3945-ucode-15.28.2.8), we need upgrade iwl3945 driver (which is being merged into iwlagn now)to the latest version?

or we keep current iwl3945 driver and iwl3945 uCode?
Comment 6 John W. Linville 2009-04-15 11:43:36 EDT
Grrr...the iwl3945-firmware update includes "Update the iwlwifi-3945-1.ucode from 2.14.1.5 to 15.28.1.8."

Reinette (or others from Intel), can you confirm that the 2.6.27-based iwl3945 is incompatible with the 15.28.1.8, despite the iwlwifi-3945-1.ucode naming scheme that was supposed to protect us from such things?
Comment 7 reinette chatre 2009-04-15 12:59:29 EDT
Few things going on here ...

- first comment talks about updating 4965 ucode. Why is update of 3945 ucode needed? Reason I ask is that I think the problem talked about in comment 1 is the "wrong command queue" issue that was fixed in 4965 ucode. We are working on getting 5k ucode out the door that fixes it for 5k hardware. This issue is not in 3945.

- the protection mentioned in comment 6 is clearly not in driver that was tested in comment 5. our backward compatibility support always tries to load the highest supported API first and if that fails it tries to load lower supported API versions. in the test in comment 5 the only version tried was version 1 so that is what that driver supports. 

- considering all the above ... do you still want to update the 3945 ucode? If so, it may help to know that 15.28.1.8 and 15.28.2.8 are actually identical (apart from the API version number). this is because the API number was incremented not because of an actual API change, but because of an incompatibility with the driver. The driver supporting APIv2 will request direct scans on passive channels which will cause SYSASSERT on ucode prior to 15.28.1.8.
Comment 8 John W. Linville 2009-04-15 13:28:20 EDT
This bug was originally cloned from an "update iwl4965" bug.  The references to iwl4965 can be ignored.

The impetus to update the firmware was simply that a later version existed.

The iwl3945 package contains iwlwifi-3945-1.ucode.

[savage]:> rpm -qpl ~/cvs/rpm/RPMS/noarch/iwl3945-firmware-15.28.2.8-2.noarch.rpm 
/lib/firmware/iwlwifi-3945-1.ucode
/lib/firmware/iwlwifi-3945-2.ucode
/lib/firmware/iwlwifi-3945.ucode
/usr/share/doc/iwl3945-firmware-15.28.2.8
/usr/share/doc/iwl3945-firmware-15.28.2.8/LICENSE
/usr/share/doc/iwl3945-firmware-15.28.2.8/README

Dongpo, are you sure you have the right iwl3945-firmware package installed?
Comment 9 DongpoLiu 2009-04-16 03:32:30 EDT
I removed the default iwlwifi uCode (iwl3945-firmware-2.14.1.5-2.noarch) from RHEL 5.3 Client Supplimentary ISO before doing this compatiblity test.

then installed iwlwifi-3945-ucode-15.28.2.8 from http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-3945-ucode-15.28.2.8.tgz,see as follows:

[root@osve-sr ~]# ls -al   /lib/firmware/  | grep iwlwifi 
-rw-r-----  1 root root 163840 Apr  9 14:53 iwlwifi-3945-ucode-15.28.2.8
-rw-r--r--  1 root root 187608 Jul  3  2008 iwlwifi-4965-1.ucode
-rw-r--r--  1 root root 187672 Jul  3  2008 iwlwifi-4965-2.ucode
-rw-r--r--  1 root root 191332 Jul 15  2007 iwlwifi-4965.ucode
Comment 10 John W. Linville 2009-04-16 08:40:07 EDT
That clearly seems like the source of the problem. :-)  You don't have a /lib/firmware/iwlwifi-3945-1.ucode file...

Do you have access to iwl3945-firmware-15.28.2.8-2.noarch.rpm?  If not, I can try to get it to you (perhaps through John V.).
Comment 11 DongpoLiu 2009-04-16 20:48:39 EDT
I donot have the iwl3945-firmware-15.28.2.8-2.noarch.rpm, pls give one to me. thanks
Comment 12 John W. Linville 2009-04-17 09:16:09 EDT
I sent you the package in private email.
Comment 13 DongpoLiu 2009-04-21 20:48:56 EDT
After installed the iwl3945-firmware-15.28.2.8-2.noarch.rpm, iwl3945 interface can be found by RHEL OS.
Comment 16 errata-xmlrpc 2009-09-02 05:10:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1253.html

Note You need to log in before you can comment on or make changes to this bug.