Bug 48829 - missing fonts.dir after installing XFree86-75dpi-fonts
missing fonts.dir after installing XFree86-75dpi-fonts
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 20:59 EDT by Jonathan Kamens
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 20:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-07-11 20:59:43 EDT
I had XFree86-75dpi-fonts-4.1.0-0.5.9.i386.rpm installed.  I upgraded to
XFree86-75dpi-fonts-4.1.0-0.8.6.i386.rpm.  It told me that it was saving
/usr/X11R6/lib/X11/fonts/75dpi/fonts.dir to fonts.dir.rpmsave, and indeed
it did, but it didn't create a new fonts.dir file!

My first guess for why this happened is because it calls mkfontdir without
a path, and mkfontdir wasn't in my path when I ran the upgrade because
/usr/X11R6/bin wasn't in my path.  But I upgraded XFree86-100dpi-fonts at
the same time, and that upgrade did create a new fonts.dir file even though
it, too, calls mkfontdir without an absolute path.  So I'm not sure why the
new fonts.dir file wasn't created.
Comment 1 Mike A. Harris 2001-07-12 04:45:09 EDT
I have made mkfontdir explicitly pathed now in the specfile.  This should
fix it in all XFree86 packages and subpackages.  Our other font packages
need to be fixed as well possibly.  I believe this should fix it in
4.1.0-0.9.0 and later.  When it is put in the tree if it does not fix it
for you, please reopen the bug and provide any new info you might have to
track down the problem.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.