Bug 488373 - pdfcube 0.0.3 fails to build on x86_64
pdfcube 0.0.3 fails to build on x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pdfcube (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Mads Villadsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 17:37 EST by Mads Villadsen
Modified: 2009-06-26 22:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.0.3-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-14 02:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Villadsen 2009-03-03 17:37:30 EST
pdfcube fails to build on x86_64 with the following error during configure:

checking for boostlib >= 1.33.1... yes
checking whether the Boost::Program_Options library is available... yes
configure: error: Could not link against  !
error: Bad exit status from /var/tmp/rpm-tmp.JvuNxQ (%build)
    Bad exit status from /var/tmp/rpm-tmp.JvuNxQ (%build)
RPM build errors:
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/pdfcube.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 324, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/pdfcube.spec']
LEAVE do --> EXCEPTION RAISED
Comment 1 Fedora Update System 2009-05-26 17:41:40 EDT
pdfcube-0.0.3-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/pdfcube-0.0.3-4.fc11
Comment 2 Susi Lehtola 2009-05-26 17:46:23 EDT
*** Bug 488374 has been marked as a duplicate of this bug. ***
Comment 3 Susi Lehtola 2009-05-26 17:47:17 EDT
As this bug has been created by the package maintainer, it hasn't been touched
in almost two months and it breaks upgrades from older releases, I fixed the
issue in CVS and built and submitted the update in updates-testing.

The problem was quite easy to fix, just adding --with-boost-libdir=%{_libdir}
to %configure was enough.
Comment 4 Fedora Update System 2009-05-28 03:58:55 EDT
pdfcube-0.0.3-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pdfcube'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5544
Comment 5 Bug Zapper 2009-06-09 07:50:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Update System 2009-06-26 22:56:01 EDT
pdfcube-0.0.3-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.