Bug 488375 - Evolution Calendar Changes Meeting Times During DST Changeover
Evolution Calendar Changes Meeting Times During DST Changeover
Status: CLOSED DUPLICATE of bug 490218
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.2
i686 Linux
high Severity high
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 17:47 EST by Russell Doty
Modified: 2009-06-16 12:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 12:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 574670 None None None Never

  None (edit)
Description Russell Doty 2009-03-03 17:47:20 EST
Description of problem:

During the period between the beginning of the current US DST change and the traditional US DST change (roughly March 9-April 3) some meetings are shifted by one hour. 

This only impacts some meetings - some meetings retain their correct (initial) time.

The problem appears to go away after April 3.

This problem seems to occur during the DST transition every year.

Version-Release number of selected component (if applicable):

RHEL 5.2 CSB with Evolution 2.12.3


How reproducible:

Every year...

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2009-03-03 18:31:34 EST
I assume this is for recurring meetings?  My guess is it depends on when the meetings were created and what the US DST dates were at the time of creation, according to the system's zoneinfo.
Comment 2 Russell Doty 2009-03-03 19:57:32 EST
Yes, this is for recurring meetings - I should have specified that.

This occurs every year during both DST transitions. Evolution is the only client where I experience these problems.
Comment 4 Jonathan Slavin 2009-03-12 12:27:15 EDT
Have you checked exactly when the change (i.e. back to correct times) occurs?  I'm using Evolution 2.12.3 (Fedora 8) and the changeover for me will happen on Monday, March 16.  Also, although my appointments show in the calendar an hour earlier than they should (i.e. at the non-DST time), the reminders pop up at the correct times.  

I'm wondering if this has to do with not getting it right as far as which is the 2nd Sunday in March, possibly because March 1st was a Sunday.  Odd though since my computer has gotten it right.  It does run ntpd.
Comment 5 Russell Doty 2009-03-12 12:53:29 EDT
Interesting mix of time shifts...

I have one repeating meeting that is scheduled for 11:00 today. It shows up in the calendar view at 10:00am. When you open the meeting it shows 11:00am, and the reminders show up at 11:00am. This meeting shows up at the correct 11:00am time in calendar view starting on March 26.

I have another recurring meeting next Tuesday, March 17, that shows up in the calendar view at 10:30am. When you open it, it shows up at 9:30am (the correct time). This meeting shows up at the correct 9:30am time in calendar view starting April 7.

So, I'm seeing meetings shifting in both directions in calendar view, and returning to the correct time (in calendar view) on different dates.

"I'm confused!"
Comment 6 Misho Krastev 2009-03-12 19:24:15 EDT
It looks to me Evolution does not think the Daylight Saving has starte.

Go to Preferences -> Calendar and Tasks -> General and click on "Adjust for daylight saving time". Events in this week (and in the past) do not change as I click on and off on that checkbox. Events in next week and further, do get their time changed as I click on and off.

The bug is annoying, and the high priority is high, but I hope even if it does not get resolved the calendar meetings will have their time right.
Comment 7 Russell Doty 2009-03-13 09:14:05 EDT
Daylight Savings Time was turned on. Turning it off and on shifted all meetings by an hour, including the current week.

The problem occurs during the period between traditional DST and current US DST - it looks like part of the code, specifically the part addressing the display of calendar view - has its own timezone data.

It is really puzzling that this only affects some meetings! I could deal with it if every meeting were affected, but when it only changes some meetings it gets rather confusing.
Comment 9 Milan Crha 2009-06-16 12:14:06 EDT
We found that this particular bug is cover already in the bug #490218, together with a fix included in evolution-data-server-1.12.3-16.el5, thus marking as a duplicate.

*** This bug has been marked as a duplicate of bug 490218 ***

Note You need to log in before you can comment on or make changes to this bug.