Bug 488411 - Qt4 apps randomly & occasionally dropping key presses
Qt4 apps randomly & occasionally dropping key presses
Status: CLOSED DUPLICATE of bug 488223
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 02:37 EST by Mark Summerfield
Modified: 2009-03-07 18:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 03:23:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Summerfield 2009-03-04 02:37:22 EST
I updated my system yesterday; I don't know if the Qt libraries were updated or maybe it was X11 stuff, but when I rebooted today I discovered that apps that use the Qt4 libraries, e.g., KMail, are "randomly" ignoring keypresses. For example, I write a mail and that all works but when I go to press Ctrl+Enter to send it, nothing happens. Then I try Alt+M,S but the Message menu won't pop-up. But then the next mail I send all the keypresses are accepted and everything works fine. I had the same effect in another Qt4 app (one of my own).

I don't know what can be done about it since the effect is so random. Maybe other people will notice and a pattern will emerge?

BTW I use GNOME as my window system, something KMail in particular doesn't seem over happy about.
Comment 1 Mark Summerfield 2009-03-04 02:44:28 EST
Actually, it isn't as occasional as I first thought. KMail in particular is virtually unusable from the keyboard (which means unusable for me) because it just keeps ignoring keypresses. So maybe it is a KMail-specific problem (since it doesn't seem to be affecting other Qt4 apps at the moment)?
Comment 2 Kevin Kofler 2009-03-04 02:44:47 EST
What version of Fedora are you using? Please fill in the version of Fedora, not Qt, under the "Version:" field.
Comment 3 Mark Summerfield 2009-03-04 02:57:32 EST
Sorry, I'm using Fedora 10. (Although I know that from memory, don't know where Fedora actually says which version it is.)

And the problem is not with Fedora's Qt. I just built an app with my own local version of Qt and I have the same problem, only worse since practically all keypresses are being ignored. So maybe the problem is with a recent change in X11 or its drivers?
Comment 4 Kevin Kofler 2009-03-04 03:05:53 EST
Hmmm, maybe the updated xorg-x11-drv-evdev?
Comment 5 Mark Summerfield 2009-03-04 05:49:07 EST
Is there a way I can back out of that update to see if that's it?
Comment 6 Kevin Kofler 2009-03-04 07:37:35 EST
Looks like the actual offender may be libgxim, see:
https://bugzilla.redhat.com/show_bug.cgi?id=488223
https://admin.fedoraproject.org/updates/libgxim-0.3.2-4.fc10
Comment 7 Mark Summerfield 2009-03-04 07:47:46 EST
I'm not convinced. I use GNOME terminal and have no problems with it at all. Nor do I have problems with Firefox or other non-Qt4 apps.
Comment 8 Mark Summerfield 2009-03-05 03:23:41 EST
I just did a yum update and got the new libgxim & rebooted. So far none of yesterday's problems have occurred, so I'll mark the bug as closed.
Thanks!
Comment 9 Kevin Kofler 2009-03-07 18:10:51 EST

*** This bug has been marked as a duplicate of bug 488223 ***

Note You need to log in before you can comment on or make changes to this bug.