Bug 488431 - check-oracle-space-usage.sh should not report high usage on UNDO tablespace
check-oracle-space-usage.sh should not report high usage on UNDO tablespace
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Mráka
Martin Minar
: Triaged
: 494891 (view as bug list)
Depends On:
Blocks: sat540-blockers
  Show dependency treegraph
 
Reported: 2009-03-04 04:43 EST by Michael Mráka
Modified: 2016-07-03 20:54 EDT (History)
11 users (show)

See Also:
Fixed In Version: spacewalk-web-0.7.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 11:02:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Mráka 2009-03-04 04:43:46 EST
Description of problem:
check-oracle-space-usage.sh reports high usage on UNDO tablespace. Space in UNDO tablespace is recycled so it doesn't make a sense to report that.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL4-re20090227.1
spacewalk-dobby-0.5.14-1.el4sat

How reproducible:
always

Steps to Reproduce:
1. check UNDO tbs usage: 
 # su - oracle -c 'db-control report'
2. consume free space in UNDO_TBS (db session 1):
 # sqlplus rhnsat/rhnsat@rhnsat
 SQL> create table undoconsumer as select s.* from user_source s,
        (SELECT rownum FROM dual CONNECT BY LEVEL <= 1000) t1000;
3. create db session 2 (connect from another terminal) and run query against undoconsumer:
 # sqlplus rhnsat/rhnsat@rhnsat
 SQL> select count(*) from undoconsumer;
4. from db session 1 run:
 SQL> update undoconsumer set line = line+1;
5. wait until db session 1 ends or fails with ORA-30036 (it takes about 15 mins)
6. check if UNDO_TBS is exhausted:
 # su - oracle -c 'db-control report'
7. run space report
 # /etc/cron.daily/check-oracle-space-usage.sh

Actual results:
Warning email:
This is a notice to let you know that you have gone over 90% usage in one of the
 Oracle Tablespaces. We recommend to be proactive and increase the size of the t
ablespace before getting to 100% usage. Please consult the Satellite documentati
on on using db-control to increase the size or contact Red Hat Support for assis
tance.

Tablespace                  Size    Used   Avail   Use%
DATA_TBS                    7.3G  708.4M    6.7G     9%
SYSAUX                      250M   71.7M  178.2M    29%
SYSTEM                      400M  242.9M    157M    61%
UNDO_TBS                    500M    500M      0M   100%
USERS                       128M     64K  127.9M     0%


Expected results:
no email

Additional info:
Comment 4 Brandon Perkins 2009-04-09 10:50:21 EDT
*** Bug 494891 has been marked as a duplicate of this bug. ***
Comment 8 Michael Mráka 2009-09-01 08:31:15 EDT
Fixed in spacewalk
commit 1e9649e6ed001e30f826dfaff9097089e6aed40b
    488431 - don't report high usage on UNDO
Comment 11 Miroslav Suchý 2010-10-20 06:10:04 EDT
I followed steps to reproduce and did not get any email
verified in stage.
Comment 12 Clifford Perry 2010-10-28 10:56:52 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.