Bug 488463 - evolution: depends on redhat-artwork, but this dependency not mentioned in the *.spec file
evolution: depends on redhat-artwork, but this dependency not mentioned in th...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution (Show other bugs)
3.9
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 08:55 EST by Jan Lieskovsky
Modified: 2009-03-04 10:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 10:48:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2009-03-04 08:55:37 EST
Description of problem:

1, file /usr/share/applications/redhat-email.desktop 
/usr/share/applications/redhat-email.desktop: symbolic link to /usr/share/desktop-menu-patches/redhat-email.desktop

2, vi /usr/share/desktop-menu-patches/redhat-email.desktop

     40 Exec=evolution
     41 Icon=redhat-email.png

3, rpm -ql evolution | grep redhat-email.png | wc -l
 0

4,  rpm -qf /usr/share/pixmaps/redhat-email.png 
redhat-artwork-0.73.3-2E.i386

Version-Release number of selected component (if applicable):
evolution-1.4.5-23.el3.*

How reproducible:
Always

Steps to Reproduce:
1. See Description
  
Actual results:
Running nautilus in /usr/share/desktop-menu-patches/ works because
redhat-artwork is already installed.

Expected results:
redhat-artwork dependency should be mentioned in evolution's spec file.

Additional info:
Comment 1 Matthew Barnes 2009-03-04 09:58:42 EST
Unless you want me to slip this into a security update, it's too late to fix.
Comment 2 Matthew Barnes 2009-03-04 10:32:48 EST
I should've read your email first.  So this comes from an rpmdiff warning.

  https://errata.devel.redhat.com/rpmdiff/show/36984.?result_id=349360

It's not worth seeking PM approval flags for this.  I'll just fix it as part of the security update, since it's a trivial one-line change to the package spec.

Note You need to log in before you can comment on or make changes to this bug.