Bug 488481 - Can't see the entire screen with the live CD
Can't see the entire screen with the live CD
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 10:45 EST by Emanuele Bellini
Modified: 2010-02-26 08:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 08:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My screen (844.57 KB, image/jpeg)
2009-03-04 10:45 EST, Emanuele Bellini
no flags Details
My Xorg log file (27.59 KB, text/plain)
2009-03-07 08:43 EST, Emanuele Bellini
no flags Details
My new Xorg log file (67.29 KB, application/octet-stream)
2009-04-29 17:38 EDT, Emanuele Bellini
no flags Details

  None (edit)
Description Emanuele Bellini 2009-03-04 10:45:41 EST
Created attachment 334008 [details]
My screen

Description of problem:
I've got a Nvidia Geforce FX5200 video card. Since I tried live CDs I always had that the desktop is moved compared to the visible screen, so in the left edge of the screen I have a black band of about 16px and in the right one I can't see what's there. You can see it in the attached photo. I have a screen resolution of 1024x768.
The problem is solved when I install the official drivers, which is impossible in the LiveCD mode.


Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-2.1.12-7.fc11.i386.rpm


How reproducible:
Always.

  
Additional info:
Also had this problem with Fedora 10 beta and Ubuntu 7.04 live CDs.
Comment 1 Matěj Cepl 2009-03-05 18:50:50 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

When the LiveCD crashes, please, switch to the console (Ctrl+Alt+F2) and cp /tmp/X* and/or (if it exists) /var/log/Xorg.*.log files to some other place -- USB stick, some other computer via network, some on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Ben Skeggs 2009-03-05 18:55:45 EST
After you've completed the install, can you run a full update and see if the issue still occurs?  Fedora has switched to the nouveau driver for NVIDIA GPUs, but that change didn't make it in time for the alpha LiveCD.
Comment 3 Emanuele Bellini 2009-03-07 08:41:35 EST
No, there's a misunderstanding: the LiveCD doesn't crash! It works for me, but, I repeat, the visible area is moved compared to the screen so I can't move the mouse arrow to the left of the screen (the screen itself doesn't reach it) and I can move it out of the right of the screen, but I don't know where it goes (D'you see? In the image I can't see the clock and the trash icon. In the same way I have a black band on the left).
I'm going to attach the Xorg.0.log file, the other doesn't exist.
About the updates, unfortunately I haven't enough free space in my computer to install Fedora. All I can do is rebooting Gnome. Anyway I tried to update the system, I couldn't because yum hasn't found the needed packages.
Moreover, I posted this bug here because I'm new to Bugzilla, but now that I know how it works I was wondering if it was better to move upstream this issue, since I had this problem also with other Linux distributions.
Comment 4 Emanuele Bellini 2009-03-07 08:43:20 EST
Created attachment 334396 [details]
My Xorg log file
Comment 6 Emanuele Bellini 2009-03-18 06:53:16 EDT
I'm waiting for the the beta LiveCD to try the new drivers.
Comment 7 Emanuele Bellini 2009-04-08 12:27:47 EDT
Done...! But I still have the issue with the new drivers (if you put them in the beta freeze, of course).
Comment 8 Ben Skeggs 2009-04-23 00:37:11 EDT
Can you post an updated /var/log/Xorg.0.log please?
Comment 9 Emanuele Bellini 2009-04-29 17:38:10 EDT
Created attachment 341843 [details]
My new Xorg log file

Sorry for making you wait, I'm very busy now.
Comment 10 Bug Zapper 2009-06-09 07:51:33 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Matěj Cepl 2009-11-05 13:22:30 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 12 Matěj Cepl 2010-02-26 07:16:32 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 13 Emanuele Bellini 2010-02-26 08:07:31 EST
Sorry, I had some problems with my PC and I couldn't post any information. I can't use it any more.

Note You need to log in before you can comment on or make changes to this bug.