Bug 488512 - uriparser: please update to 0.7.5
uriparser: please update to 0.7.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: uriparser (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On: 488908
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 12:58 EST by Jose Pedro Oliveira
Modified: 2009-04-14 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 12:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2009-03-04 12:58:16 EST
Description of problem:
The current rawhide version is 0.7.1 (uriparser-0.7.1-7.fc11). The latest upstream version is 0.7.5.


Additional info:
http://uriparser.svn.sourceforge.net/viewvc/uriparser/uriparser/tags/uriparser-0.7.5/ChangeLog

2009-03-04 -- 0.7.5

  * Added: pkg-config file
  * Fixed: File Doxyfile.in was missing from release archives
      Thanks to Rakesh Pandit for reporting!
  * Fixed: Doc generation troubles
  * Changed: No longer shipping bundled libcpptest
  * Changed: New dependencies:
      - libcpptest 1.1.0 or later
      - pkg-config (for libcpptest detection)
      Both dependencies can be disable through configuring
      with --disable-test, which excludes the test suite
      from compilation.
  * Soname: 1:10:0

2008-12-23 -- 0.7.4

  * Fixed: Null pointer de-referencing when dissecting query
      strings starting with "&" right after "?" (#2418192).
      Thanks to Harvey Vrsalovic for reporting!
  * Fixed: Memory leak in uriFreeQueryList function (#2413066)
      Thanks to Daniel Chapiesky for reporting!
  * Fixed: Memory leak in uriNormalizeSyntax(Ex) functions (#2413066)
      Thanks to Daniel Chapiesky for reporting!
  * Improved: Nested configure hacks resolved
  * Soname: 1:9:0

2008-11-08 -- 0.7.3

  * Fixed: Missing NULL check in parsing routines
      Thanks to Sezai Tekin for reporting!
  * Fixed: uriparser now builds on Cygwin
  * Fixed: Now shipping gnulib's config.guess from HEAD
      which is suitable for Haiku (#2116355)
  * Changed: swprintf requirement resolved
  * Changed: Build system changes:
      - configure option --enable-doc added
      - configure.in renamed to configure.ac
      - some Autotools files moved to build-aux directory
  * Added: Qt Assistant documentation output:
      - Qt Compressed Help (.qch) at <doc/uriparser-doc-*.qch>
      - Qt Help Project (.qhp) at <doc/html/index.qhp>
      Generation requires Doxygen 1.5.7.1-20081103 or later.
  * Soname: 1:8:0

2008-09-01 -- 0.7.2

  * Fixed: Bad cleanup logic in functions
      - uriAddBaseUri(..)
      - uriRemoveBaseUri(..)
      Previously you needed to call uriFreeUriMembers on return code
      URI_ERROR_MALLOC and only then. So that's why these functions now
      take cleanup off your shoulders. An extra call to uriFreeUriMembers
      from your side is still needed in case of success.
  * Soname: 1:7:0
Comment 1 Rakesh Pandit 2009-03-05 23:32:34 EST
It has a buildrequire cpptest which seems to be adsent .. I will get this in first.
Comment 2 Rakesh Pandit 2009-03-06 00:56:19 EST
As soon as this is reviewed I will update uriparser https://bugzilla.redhat.com/show_bug.cgi?id=488908
Comment 3 Rakesh Pandit 2009-03-07 15:04:02 EST
My update is ready

http://rakesh.fedorapeople.org/srpm/uriparser-0.7.5-1.fc10.src.rpm

As soon as someone reviews cpptest .. and I push it .. After that I can push this one.
Comment 4 Rakesh Pandit 2009-04-13 14:14:26 EDT
Cpptest is now in rawhide. Will push uriparser 0.7.5 tomorrow before window closes down.
Comment 5 Rakesh Pandit 2009-04-14 12:25:31 EDT
Pushed to rawhide.
Comment 6 Jose Pedro Oliveira 2009-04-14 12:33:37 EDT
Rakesh,

Thanks.

jpo

Note You need to log in before you can comment on or make changes to this bug.