Bug 488537 - RFE: Method to Import Local CA Certificates
RFE: Method to Import Local CA Certificates
Status: CLOSED DUPLICATE of bug 466626
Product: Fedora
Classification: Fedora
Component: ca-certificates (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2009-03-04 13:43 EST by Daniel Qarras
Modified: 2009-05-28 06:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-05-28 06:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2009-03-04 13:43:39 EST
Description of problem:
In enterprise world different departments set up services and put them behind https using certificates signed with local corporate CA certificates. In Fedora real CA certificates are provided in system level by files


These are part of RPMs and modifying them is not feasible (e.g., RPM upgrades will wipe locally added CA certs away).

A method to add local CA certs in system level is needed.
Comment 1 Daniel Qarras 2009-03-05 16:31:21 EST
BTW, this would probably be also very useful with things like IPA which use (by default) a self create CA cert and then issue certificates to clients.
Comment 2 Joe Orton 2009-05-28 06:21:29 EDT

*** This bug has been marked as a duplicate of bug 466626 ***

Note You need to log in before you can comment on or make changes to this bug.