Bug 488540 - RFE: Unified Way to Refer to Installation Media
RFE: Unified Way to Refer to Installation Media
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 13:57 EST by Daniel Qarras
Modified: 2009-03-29 06:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-29 06:16:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2009-03-04 13:57:35 EST
Description of problem:
Anaconda handles CD and USB installations differently, one can refer to installation CD by using device name (/dev/sd??) independent syntax ks=cdrom:/path/ks.cfg. However, for USB no similar syntax is available, using something like ks=hd:sdb1:/path/ks.cfg is dependent on the system where installation is done.

It would be nice to have something like ks=src:/path/ks.cfg.

It also seems that in case of ks=... path being incorrect, CD installation will automagically check for /updates directory for updates.img etc but this does not happen with USB installations. Also in this case unification between CD/USB/DVD/SD/etc would be highly beneficial as scripting to create kickstart files etc becomes much easier and with a large set of users and systems it is impossible to know all the combinations they are used beforehand.
Comment 1 Chris Lumens 2009-03-26 15:17:33 EDT
I've never really liked the cdrom: shortcut, but it works because most people really only have one optical device.  However, you can have many USB drives attached at any one time which makes providing such a shortcut a little impractical.

However, recently we have added the ability to specify devices by both label and UUID.  So, you could do:

ks=hd:LABEL=whatever:/path/ks.cfg or ks=hd:UUID=1234-5678-9abc:/path/ks.cfg

That doesn't require you to play a guessing game with device nodes between computers.  Does this capability provide what you are looking for?
Comment 2 Daniel Qarras 2009-03-29 06:15:36 EDT
> ks=hd:LABEL=whatever:/path/ks.cfg or ks=hd:UUID=1234-5678-9abc:/path/ks.cfg
> 
> That doesn't require you to play a guessing game with device nodes between
> computers.  Does this capability provide what you are looking for?

Yes! This is exactly what I needed and - to be very honest - implemented much smarter than I was personally thinking! (As a very modest request I hope this will be added to the documentation some day :)

Thanks a lot, I'll close this one!

Note You need to log in before you can comment on or make changes to this bug.