Bug 488559 - samba built without POSIX capabilities which causes severe performance problems
samba built without POSIX capabilities which causes severe performance problems
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
http://thread.gmane.org/gmane.network...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 15:28 EST by Leo Bergolth
Modified: 2009-03-30 17:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.2.8-0.26.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 11:28:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo Bergolth 2009-03-04 15:28:05 EST
Description of problem:

The Fedora spec-file misses a dependency on libcap-devel.
Because of this, the current samba rpm is built without support for POSIX capabilities which results for example in broken oplock support. This leads to file buffering being completely disabled.

See
http://thread.gmane.org/gmane.network.samba.general/104511/focus=104535
for details.

Simply adding libcap-devel to Build-Requires should be sufficient to fix
this.

Version-Release number of selected component (if applicable):
Seems to apply to all samba packages in current fedora versions.

How reproducible:
http://kojipkgs.fedoraproject.org/packages/samba/3.2.8/0.26.fc10/data/logs/i386/build.log
Comment 1 Fedora Update System 2009-03-05 07:20:59 EST
samba-3.2.8-0.27.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/samba-3.2.8-0.27.fc10
Comment 2 Fedora Update System 2009-03-05 07:21:38 EST
samba-3.2.8-0.26.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/samba-3.2.8-0.26.fc9
Comment 3 Fedora Update System 2009-03-05 11:28:43 EST
samba-3.2.8-0.27.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2009-03-05 11:33:50 EST
samba-3.2.8-0.26.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Trevor Cordes 2009-03-30 15:33:36 EDT
Leo, did the 3.2.8-0.27.fc10 update fix your problem?  I'm running it and I am seeing similar behaviour to your samba list report still.  Can you confirm?
Comment 6 Leo Bergolth 2009-03-30 17:07:30 EDT
I'm still running a samba version that I built myself on the corresponding box.
However, it should fix the problem since the new package depends on libcap and smbd is linked against it:

$ rpm -q samba-3.2.8-0.27.fc10 --requires | grep libcap
libcap.so.2

$ ldd /usr/sbin/smbd | grep libcap
        libcap.so.2 => /lib/libcap.so.2 (0x001cb000)

Note You need to log in before you can comment on or make changes to this bug.