Bug 488578 - kde kmenu Logout item does absolutely nothing
kde kmenu Logout item does absolutely nothing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 16:00 EST by long
Modified: 2009-09-07 22:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 22:07:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description long 2009-03-04 16:00:03 EST
Description of problem:
If I go into kmenu and go to the Leave tab and click the Logout entry absolutely nothing happens.  I've clicked it at least twice now in the last 10 minutes and yet I have not had my session ended.  Nothing shows up out of the ordinary on top.  

Version-Release number of selected component (if applicable):
kdebase-workspace-4.2.0-8.fc10.x86_64 (and i386)


How reproducible:
Every time.

Steps to Reproduce:
1. go into kmenu
2. go into the Leave tab
3. click Logout
  
Actual results:
nothing

Expected results:
My session ends and I'm back at gdm

Additional info:
If I add the Lock/Logout widgets to my panel they do seem to work.
Comment 1 Rex Dieter 2009-03-04 16:12:01 EST
Can you reproduce using kdm?

ie, either remove gdm and/or edit /etc/sysconfig/desktop to contain:
DESKTOPMANAGER=KDE

and reboot.
Comment 2 Rex Dieter 2009-03-04 16:14:48 EST
For what its worth, just double-checked checked, works ok on my boxen using either gdm or kdm.

wonder what's going wrong... ?
Comment 3 long 2009-03-04 17:17:41 EST
did you mean DISPLAYMANAGER=KDE?  the other didn't seem to do anything

anyway, using kdm seems to have had no effect, I've clicked the Logout menu item several times this session and nothing is happening :-(

Going out on a limb I would almost say it is something specific to however I configure KDE as it happens on both my home and work systems.  And I don't think it started until F8 -> F10 and possibly not until the 4.2 upgrade or so.
Comment 4 Rex Dieter 2009-03-04 18:28:36 EST
yes DISPLAYMANAGER (sorry).

More details, 
rpm -q kdelibs kdebase-workspace
what video hw/driver do you use?
Any selinux-related warnings/denials?
Comment 5 long 2009-03-05 12:27:26 EST
[long@griffon wnkmu4iv.slt]$ rpm -q kdelibs kdebase-workspace
kdelibs-4.2.0-15.fc10.i386
kdebase-workspace-4.2.0-8.fc10.i386

On this machine I'm using the radeon driver.  At home I use the binary nvidia driver.

I do not appear to be getting any selinux messages during this.
Comment 6 Steven M. Parrish 2009-04-27 14:51:38 EDT
Is this still an issue?
Comment 7 long 2009-04-27 15:49:42 EDT
Yes, it still seems to do nothing for me.  Using:

kdelibs-4.2.2-7.fc10.i386
kdebase-workspace-4.2.2-3.fc10.i386
Comment 8 Rex Dieter 2009-05-21 08:49:17 EDT
Sorry no one but you can reproduce. 

Is desktop effects enabled?  (If so, please try disabling, and logout/login and/or reboot)

Does, 
Alt-F2 (krunner):   logout
do anything?
Comment 9 long 2009-05-21 18:08:32 EDT
That figures :-)

Desktop effects were not enabled to begin with.

krunner -> logout did in fact end my session and log me out (although ksmserver refused to start and booted me out of my following KDE session, does that offer any hints?)
Comment 10 Steven M. Parrish 2009-05-26 10:04:47 EDT
Seems no one here can reproduce this behaviour.  I would suggest checking upstream at http://bugs.kde.org to see if anyone else has reported this.  If not please file an upstream report and update this report with the upstream information.
Comment 11 long 2009-05-27 19:10:43 EDT
Some new info, if I go into System Settings -> Session Manager and check "Confirm logout" then the K menu logout button works normally for me (it asks for confirmation, then logs me out).
Comment 12 Steven M. Parrish 2009-09-07 22:07:06 EDT
Since no one else could reproduce and you now have it working going to close this.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.