Bug 488586 - cuetag.sh is broken due to deprecated parameters in flac
cuetag.sh is broken due to deprecated parameters in flac
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cuetools (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul P Komkoff Jr
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 16:09 EST by Felix Kaechele
Modified: 2009-07-19 06:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4.0-0.4.svn305.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-19 06:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for cuetag.sh to work with flac > 1.1.4 (440 bytes, patch)
2009-03-04 16:09 EST, Felix Kaechele
no flags Details | Diff
Update spec file with fixes for #488586 and #499910 (5.87 KB, patch)
2009-05-08 17:20 EDT, Todd Zullinger
no flags Details | Diff

  None (edit)
Description Felix Kaechele 2009-03-04 16:09:05 EST
Created attachment 334069 [details]
Patch for cuetag.sh to work with flac > 1.1.4

Here's a patch for the cuetag.sh to fix it when working with flac > 1.1.4
I've sent a notice upstream, however this bug is known and there hasn't happened anything since then. See http://developer.berlios.de/bugs/?func=detailbug&bug_id=11402&group_id=2130

For the source file: wouldn't it be more feasible to include a svn snapshot instead of patching the old source?
Comment 1 Todd Zullinger 2009-05-08 17:20:32 EDT
Created attachment 343179 [details]
Update spec file with fixes for #488586 and #499910

FWIW, I ran into this a while back and used the same patch to correct it.  In case it helps, here's a patch against the devel branch to udpdate the spec file and include patches to fix this bug as well as #499910.
Comment 2 Bug Zapper 2009-06-09 07:52:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Leszek Matok 2009-07-01 18:25:54 EDT
Paul, are you alive?

The patch above contains three trivial patches and all necessary changes to the spec file. This is as little maintenance as only a maintainer can dream of.

Please apply, as there are other people hitting this and patching by themselves (and for this particular bug, the old syntax is deprecated for 5 years already, I'd be ashamed for not fixing that ;)).
Comment 4 Paul P Komkoff Jr 2009-07-04 14:12:41 EDT
Sorry, I am being lame.
Fixing ...
Comment 5 Fedora Update System 2009-07-15 11:15:33 EDT
cuetools-1.4.0-0.4.svn305.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/cuetools-1.4.0-0.4.svn305.fc10
Comment 6 Fedora Update System 2009-07-15 11:15:49 EDT
cuetools-1.4.0-0.4.svn305.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cuetools-1.4.0-0.4.svn305.fc11
Comment 7 Fedora Update System 2009-07-19 06:06:38 EDT
cuetools-1.4.0-0.4.svn305.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-07-19 06:14:49 EDT
cuetools-1.4.0-0.4.svn305.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.