Bug 488603 - In KickstartScriptEdit, leaving "scripting language" as blank results in unusable kickstart file.
In KickstartScriptEdit, leaving "scripting language" as blank results in unus...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Partha Aji
John Matthews
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-03-04 16:40 EST by John Matthews
Modified: 2009-09-10 15:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:24:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2009-03-04 16:40:32 EST
Description of problem:

When adding steps to a "script" for a kickstart, I left the "scripting language" empty, as the tooltip said it would use the install-time shell if I left it blank.  I then attempted to do a kickstart and received an error message that no argument was given to interpreter.

/rhn/kickstart/KickstartScriptEdit.do

This is the text on the page:

Examples: '/usr/bin/python' '/usr/bin/perl'.
Tip: Leave this field blank to use the install-time shell as language for your post script.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090227.1-i386-embedded-oracle.iso

How reproducible:
Always

Steps to Reproduce:
1. Create kickstart
2. Add a post script to run in chroot
3. Add some steps and leave "scripting language" blank
4. Look at the generated kickstart file
  
Actual results:
Near the end of the kickstart file you will see the steps you added, look at the "%post --interpreter" line.  There is no program specified for the interpreter.  



Expected results:
%post --interpreter /bin/bash
or
%post --interpreter /bin/sh



Additional info:

This is the script I'm running for my test.

%post --interpreter /bin/bash
mkdir /tmp/centos5-tools-channel
cd /tmp/centos5-tools-channel
wget -r -l 1 -nd http://rlx-3-22.rhndev.redhat.com/pub/centos5-tools-channel
rpm -Uvh *.rpm
rhnreg_ks --serverUrl=http://rlx-3-22.rhndev.redhat.com/XMLRPC --activationkey=1-centos5-key --force
Comment 1 Partha Aji 2009-04-09 20:44:11 EDT
I could not reproduce this issue. Kickstart format specified in http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Installation_Guide/s1-kickstart2-postinstallconfig.html says that we can leave it just as %post if no interpreter is specified I just tested and it looks like we are indeed doing that.. I could not locate "%post --interpreter" with a blank showing up.. 

The only time I was able to reproduce the above issue was when we had a space, i.e. " " (without the quotes) for the interpreter when generating the post script.. This should be fixed in the next iso
http://git.fedorahosted.org/git/spacewalk.git?p=spacewalk.git;a=commit;h=2bf22ba666bb6f688c8cbac58e8e7dc38f57e406
Comment 2 Partha Aji 2009-04-22 13:41:59 EDT
moving to On_QA
Comment 4 Partha Aji 2009-05-20 10:23:46 EDT
Moving to ON_QA
Comment 6 Shannon Hughes 2009-07-29 13:26:26 EDT
verified on sun-x4200-01.rhts.bos.redhat.com
Comment 7 Brandon Perkins 2009-09-10 15:24:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.