Bug 48862 - /etc/cron.daily/makewhatis.cron from man-1.5i2-0.6x produces lstat() directory error message
/etc/cron.daily/makewhatis.cron from man-1.5i2-0.6x produces lstat() director...
Status: CLOSED DUPLICATE of bug 47784
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-12 04:51 EDT by sundell
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 04:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sundell 2001-07-12 04:51:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.20pre6 i686; Nav)

Description of problem:
Since installing the man-1.5i2-0.6x package on several machines, I have
received, every night without fail, these two errors from cron on each
machine (from the makewhatis cron script):

error: lstat() of directory /var/cache/man/X11R6/cat? failed: No such file
or directory
error: lstat() of directory /var/catman/X11R6/cat? failed: No such file or
directory
 

How reproducible:
Always

Steps to Reproduce:
1. Install man-1.5i2-0.6x.
2. Drink some coffee so you can stay up.
3. Read your email at 4:05am.
	

Actual Results:  There is mail from cron containing the errors above.

Expected Results:  No output.

Additional info:

Upgraded to man-1.5i2-0.6x from man-1.5i-0.6x.  No part of man.config or
any file or directory that seems remotely related to man has been touched.

cron indicates this environment:
X-Cron-Env: <SHELL=/bin/bash>
X-Cron-Env: <PATH=/sbin:/bin:/usr/sbin:/usr/bin>
X-Cron-Env: <MAILTO=root>
X-Cron-Env: <HOME=/>
X-Cron-Env: <LOGNAME=root>
 
output of man --path (from cron):
/usr/man:/usr/X11R6/man:/usr/local/man:/usr/kerberos/man:/usr/lib/perl5/man

some directory listings:
% ls -l /var/catman
total 0
% ls -l /var/cache/man
total 6
-rw-r--r--    1 root     root         5379 Jul  9 04:02 whatis

I tried removing that 'whatis' file (apparently it's left over from the
night before the upgrade -- why was it not removed?), but that did not
alter the behavior.

I love man-1.5i2 -- so far, looks like it's been a barrel of laughs.
Comment 1 Bernhard Rosenkraenzer 2001-07-12 10:36:22 EDT

*** This bug has been marked as a duplicate of 47784 ***

Note You need to log in before you can comment on or make changes to this bug.