Bug 488675 - accelerator keys is ignored
accelerator keys is ignored
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 01:23 EST by Michael
Modified: 2009-03-27 10:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.105.1-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 10:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael 2009-03-05 01:23:08 EST
Description of problem:
Prior to the last system update fontforge worked just fine.
After the update no key strike has *any* affect!
In the update the packages on the list were updated:

[root@ex ~]# grep "yum: " /var/log/messages
Mar  4 07:07:36 ex yum: Updated: selinux-policy-3.5.13-46.fc10.noarch
Mar  4 07:07:43 ex yum: Installed: system-config-date-1.9.36-1.fc10.noarch
Mar  4 07:07:46 ex yum: Updated: kernel-firmware-2.6.27.19-170.2.35.fc10.noarch
Mar  4 07:07:50 ex yum: Installed: system-config-date-docs-1.0.5-1.fc10.noarch
Mar  4 07:08:54 ex yum: Updated: selinux-policy-targeted-3.5.13-46.fc10.noarch
Mar  4 07:08:57 ex yum: Updated: selinux-policy-doc-3.5.13-46.fc10.noarch
Mar  4 07:09:23 ex yum: Updated: kernel-doc-2.6.27.19-170.2.35.fc10.noarch
Mar  4 07:10:26 ex yum: Installed: kernel-devel-2.6.27.19-170.2.35.fc10.i686
Mar  4 07:10:29 ex yum: Updated: kernel-headers-2.6.27.19-170.2.35.fc10.i386
Mar  4 07:10:33 ex yum: Updated: gvfs-1.0.3-6.fc10.i386
Mar  4 07:10:33 ex yum: Updated: audit-libs-1.7.12-1.fc10.i386
Mar  4 07:10:35 ex yum: Updated: gtkhtml3-3.24.5-1.fc10.i386
Mar  4 07:10:39 ex yum: Updated: evolution-data-server-2.24.5-1.fc10.i386
Mar  4 07:11:23 ex yum: Updated: evolution-2.24.5-1.fc10.i386
Mar  4 07:11:24 ex yum: Updated: 1:cups-libs-1.3.9-8.fc10.i386
Mar  4 07:11:24 ex yum: Updated: SDL-1.2.13-7.fc10.i386
Mar  4 07:11:25 ex yum: Updated: linuxwacom-0.8.0.3-8.fc10.i386
Mar  4 07:11:26 ex yum: Updated: libgxim-0.3.2-3.fc10.i386
Mar  4 07:11:28 ex yum: Updated: anthy-9100h-1.fc10.i386
Mar  4 07:11:36 ex yum: Updated: 1:cups-1.3.9-8.fc10.i386
Mar  4 07:11:36 ex yum: Updated: gvfs-gphoto2-1.0.3-6.fc10.i386
Mar  4 07:11:36 ex yum: Updated: xorg-x11-drv-vmmouse-12.6.3-3.fc10.i386
Mar  4 07:11:37 ex yum: Updated: audit-libs-python-1.7.12-1.fc10.i386
Mar  4 07:11:42 ex yum: Updated: evolution-help-2.24.5-1.fc10.i386
Mar  4 07:11:43 ex yum: Updated: gvfs-smb-1.0.3-6.fc10.i386
Mar  4 07:11:43 ex yum: Updated: gvfs-archive-1.0.3-6.fc10.i386
Mar  4 07:11:43 ex yum: Updated: evolution-perl-2.24.5-1.fc10.i386
Mar  4 07:11:44 ex yum: Updated: alsa-utils-1.0.19-2.fc10.i386
Mar  4 07:11:45 ex yum: Updated: audit-1.7.12-1.fc10.i386
Mar  4 07:11:45 ex yum: Updated: gvfs-fuse-1.0.3-6.fc10.i386
Mar  4 07:11:45 ex yum: Updated: gvfs-obexftp-1.0.3-6.fc10.i386
Mar  4 07:11:46 ex yum: Updated: sweep-0.9.3-4.fc10.i386
Mar  4 07:12:05 ex yum: Installed: kernel-2.6.27.19-170.2.35.fc10.i686
Mar  4 07:12:47 ex yum: Installed: kernel-2.6.27.19-170.2.35.fc10.i686


Version-Release number of selected component (if applicable):
fontforge-20080828-1.fc10.i386

How reproducible:
Always.

Steps to Reproduce:
1. update your system
2. launch fontforge
3. strike any key/key combination.
  
Actual results:
No key/"key combination"/hotkey works.

Expected results:
Keys shall work.

Additional info:
No error messages.
I don't think the bug has common ground with the bug 462038.
Comment 1 Kevin Fenzi 2009-03-05 01:29:51 EST
I strongly suspect: 

Mar  4 07:11:26 ex yum: Updated: libgxim-0.3.2-3.fc10.i386

Can you apply the update from: 
https://admin.fedoraproject.org/updates/libgxim-0.3.2-4.fc10

and see if that fixes it?
Comment 2 Michael 2009-03-05 02:11:49 EST
Mar  5 10:06:09 ex yum: Updated: libgxim-0.3.2-4.fc10.i386

No change. It doesn.t help.
Comment 3 Kevin Fenzi 2009-03-05 13:35:09 EST
Odd. Are you 100% sure you restarted fontforge after the above update?
Comment 4 Michael 2009-03-05 14:42:53 EST
[root@ex ~]# uptime
 22:31:03 up 4 min,  3 users,  load average: 0.42, 0.44, 0.20
[root@ex ~]# rpm -qa | grep "libgxim\|fontforge"
fontforge-20080828-1.fc10.i386
libgxim-0.3.2-4.fc10.i386
[root@ex ~]# 

I have even restarted the OS.
No change.

Well. I lied from the start. It seems that Shift and Alt work actually.
Though no other key works. No Ctrl-S, Ctrl-Z, or Alt-Ctrl-Shift-+, etc.
The mouse still works well.
Comment 5 Michael 2009-03-05 15:14:11 EST
I mean Shift and Alt work with the mouse but not in combination with other keys.
Comment 6 Kevin Fenzi 2009-03-06 16:50:41 EST
I'm at a loss what could have happened... fontforge in f10 hasn't changed in quite a while. ;( 

Can you get the older version of libgxim from: 

http://koji.fedoraproject.org/koji/buildinfo?buildID=67227

and do a 'rpm -Uvh libgxim*.rpm --oldpackage --replacepkgs' on it to go back to that version, then restart fontforge and see if it's working?
Comment 7 Michael 2009-03-07 10:24:50 EST
This one:

http://download.fedora.redhat.com/pub/fedora/linux/releases/10/Fedora/i386/os/Packages/libgxim-0.3.1-1.fc10.i386.rpm

[root@ex libgxim]# rpm -Uvh --oldpackage libgxim-0.3.1-1.fc10.i386.rpm
Preparing...                ########################################### [100%]
   1:libgxim                ########################################### [100%]
[root@ex libgxim]#

Restarting just fontforge didn't help.
I had to restart the OS:

[root@ex ~]# uptime
 18:00:45 up 1 min,  2 users,  load average: 2.20, 0.88, 0.32
[root@ex ~]# rpm -qi libgxim
Name        : libgxim                      Relocations: (not relocatable)
Version     : 0.3.1                             Vendor: Fedora Project
Release     : 1.fc10                        Build Date: Thu 23 Oct 2008 05:02:13 PM MSD
Install Date: Sat 07 Mar 2009 05:22:44 PM MSK      Build Host: xenbuilder2.fedora.redhat.com
Group       : System Environment/Libraries   Source RPM: libgxim-0.3.1-1.fc10.src.rpm
Size        : 393586                           License: LGPLv2+
Signature   : DSA/SHA1, Wed 29 Oct 2008 06:58:58 AM MSK, Key ID bf226fcc4ebfc273
Packager    : Fedora Project
URL         : http://code.google.com/p/libgxim/
Summary     : GObject-based XIM protocol library

Well. Now it works. My fontforge is back!
What's next?
Comment 8 Kevin Fenzi 2009-03-07 17:57:34 EST
I'm reassigning this to libgxim.
Comment 9 Akira TAGOH 2009-03-09 02:10:29 EDT
That looks like a bug in XIM handling code in fontforge. there are a feature to keep IM turned on but to be able to input ASCII in scim-anthy say. in this mode, I can't use shortcut keys nor accelerator keys on fontforge as well.  This is a well known issue to deal with key events. in GTK+, they resolve a kind of this issue checking accelerators before forwarding them to IM. though that way introduces another issue that keybindings in IM that acts with a prefix key for accelerators doesn't work.

I'd say this isn't a libgxim nor imsettings bugs but should be an application bug, fontforge in this case since this happens without libgxim/imsettings. moreover accelerator keys actually works in the file dialog. guess that's probably because the entry box picks up the filtered event and process accelerators.  Anyway until now no one who uses IM didn't just complain and libgxim didn't work due to a bug in Fedora 10 GA.

However there are a workaround for someone who don't really use IM - although that might affects a performance because all the key events are forwarding synchronously. but in this mode, the key events won't be filtered out unless it's something what IM converts from the key events.
Comment 10 Akira TAGOH 2009-03-09 04:13:03 EDT
I've built a testing package with the above workaround. please test it carefully. I'm not sure if this workaround should be enabled by default because that may affects a performance since all of keyevents will be sent synchronously. i.e. XFilterEvent just waits for a response and deal with it straightforward.

Testing package is:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1230892

To turn off a workaround:
% gconftool-2 -t bool -s /apps/imsettings-applet/sync_on_forward false
Comment 11 Michael 2009-03-09 09:30:35 EDT
> That looks like a bug in XIM handling code in fontforge. ...

Though it's strange to me that fontforge worked well until the impact of libgxim-0.3.2-3.fc10.i386.

Well. Now I'm again up to date with the latest version of libgxim:

[root@ex ~]# rpm -qi libgxim
Name        : libgxim                      Relocations: (not relocatable)
Version     : 0.3.2                             Vendor: Fedora Project
Release     : 4.fc10                        Build Date: Tue 03 Mar 2009 05:41:07 PM MSK
Install Date: Mon 09 Mar 2009 03:13:54 PM MSK      Build Host: xenbuilder2.fedora.redhat.com
Group       : System Environment/Libraries   Source RPM: libgxim-0.3.2-4.fc10.src.rpm
Size        : 395396                           License: LGPLv2+
Signature   : DSA/SHA1, Wed 04 Mar 2009 04:28:51 PM MSK, Key ID bf226fcc4ebfc273

and once again fontforge doesn't work anymore:

[mike@ex ~]$ rpm -qi fontforge
Name        : fontforge                    Relocations: (not relocatable)
Version     : 20080828                          Vendor: Fedora Project
Release     : 1.fc10                        Build Date: Thu 04 Sep 2008 12:11:37 AM MSD
Install Date: Fri 16 Jan 2009 05:18:31 AM MSK      Build Host: xenbuilder2.fedora.redhat.com
Group       : Applications/Publishing       Source RPM: fontforge-20080828-1.fc10.src.rpm
Size        : 16289975                         License: BSD

Ok. I take the testing package and install it:

http://koji.fedoraproject.org/koji/getfile?taskID=1230895&name=imsettings-0.105.1-3.fc10.1.i386.rpm
http://koji.fedoraproject.org/koji/getfile?taskID=1230895&name=imsettings-libs-0.105.1-3.fc10.1.i386.rpm

[root@ex libgxim]# rpm -Uhv imsettings-0.105.1-3.fc10.1.i386.rpm imsettings-libs-0.105.1-3.fc10.1.i386.rpm
Preparing...                ########################################### [100%]
   1:imsettings-libs        ########################################### [ 50%]
   2:imsettings             ########################################### [100%]
[root@ex libgxim]#

[mike@ex ~]$ rpm -qi imsettings
Name        : imsettings                   Relocations: (not relocatable)
Version     : 0.105.1                           Vendor: Fedora Project
Release     : 3.fc10.1                      Build Date: Mon 09 Mar 2009 11:06:19 AM MSK
Install Date: Mon 09 Mar 2009 03:46:10 PM MSK      Build Host: x86-3.fedora.phx.redhat.com
Group       : Applications/System           Source RPM: imsettings-0.105.1-3.fc10.1.src.rpm
Size        : 458796                           License: LGPLv2+

I guess I have to restart thanks it doesn't take much time.
Yes. Fontforge now works with:

[mike@ex ~]$ gconftool-2 --get /apps/imsettings-applet/sync_on_forward
true

=========================================================

It's strange still that even after the restart:

[mike@ex ~]$ uptime
 16:08:59 up 1 min,  2 users,  load average: 1.50, 0.47, 0.16
[mike@ex ~]$

I have:

[mike@ex ~]$ gconftool-2 --get /apps/imsettings-applet/sync_on_forward
true
[mike@ex ~]$ fontforge test.sfd &

But fontforge still doesn't work and I have to issue:

[mike@ex ~]$ gconftool-2 -t bool -s /apps/imsettings-applet/sync_on_forward true

After that fontforge works well:

[mike@ex ~]$ fontforge test.sfd &

Though there's no obvious change:

[mike@ex ~]$ gconftool-2 --get /apps/imsettings-applet/sync_on_forward
true
[mike@ex ~]$

The deal is quite tricky.
Comment 12 Akira TAGOH 2009-03-09 10:51:25 EDT
Thank you for testing.

(In reply to comment #11)
> Though it's strange to me that fontforge worked well until the impact of
> libgxim-0.3.2-3.fc10.i386.

I should do check a reproducibility on -1.fc10 first but I didn't do that but just confirmed a issue on new one. so just reverted now. but I still see this issue with even old libgxim. if you can still see fontforge working back by downgrading libgxim, please try:

% killall imsettings-applet
% LIBGXIM_DEBUG=all imsettings-applet --disable-xsettings

and run fontforge on other terminal say. I guess any keyevents isn't sending through imsettings-applet then.

> But fontforge still doesn't work and I have to issue:
> 
> [mike@ex ~]$ gconftool-2 -t bool -s /apps/imsettings-applet/sync_on_forward
> true
> 
> After that fontforge works well:
> 
> [mike@ex ~]$ fontforge test.sfd &
> 
> Though there's no obvious change:
> 
> [mike@ex ~]$ gconftool-2 --get /apps/imsettings-applet/sync_on_forward
> true
> [mike@ex ~]$
> 
> The deal is quite tricky.  

Okay. let me have a look at that. and probably push the updates with other fixes as well.
Comment 13 Fedora Update System 2009-03-17 02:55:26 EDT
imsettings-0.105.1-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/imsettings-0.105.1-4.fc10
Comment 14 Fedora Update System 2009-03-18 15:14:00 EDT
imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update imsettings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2843
Comment 15 Michael 2009-03-18 17:16:20 EDT
The update is unavailable yet:

[root@ex ~]# rpm -qa | grep imsettings
imsettings-0.105.1-3.fc10.1.i386
imsettings-libs-0.105.1-3.fc10.1.i386
[root@ex ~]# yum --enablerepo=updates-testing update imsettings
Loaded plugins: refresh-packagekit
Setting up Update Process
No Packages marked for Update
[root@ex ~]#
Comment 16 Michael 2009-03-22 01:27:20 EDT
Fontforge seems to be ok now with the patch:
$ rpm -qa | grep imsettings
imsettings-libs-0.105.1-4.fc10.i386
imsettings-0.105.1-4.fc10.i386
Comment 17 Akira TAGOH 2009-03-25 22:07:35 EDT
Great.  Thank you for testing.
Comment 18 Fedora Update System 2009-03-27 10:53:07 EDT
imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.