Bug 488707 - File "/usr/lib/python2.6/site-packages/yum/packages.py", line 664, in verifyLocalPkg (csum_type, csum) = self.returnIdSum() TypeError: 'NoneType' object is not iterable
File "/usr/lib/python2.6/site-packages/yum/packages.py", line 664, in verifyL...
Status: CLOSED DUPLICATE of bug 488673
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 06:27 EST by Michal Nowak
Modified: 2014-01-21 18:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 09:38:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-03-05 06:27:33 EST
Description of problem:

dhcp-lab-124 Download # yum localinstall qemu-*
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Local Package Process
Examining qemu-common-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm: 2:qemu-common-0.9.2-0.1.kvm20090303git.fc11.x86_64
Marking qemu-common-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm to be installed
Excluding Packages in global exclude list
Finished
Examining qemu-img-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm: 2:qemu-img-0.9.2-0.1.kvm20090303git.fc11.x86_64
Marking qemu-img-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm as an update to qemu-img-0.9.1-12.fc11.x86_64
Examining qemu-system-x86-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm: 2:qemu-system-x86-0.9.2-0.1.kvm20090303git.fc11.x86_64
Marking qemu-system-x86-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm to be installed
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package qemu-common.x86_64 2:0.9.2-0.1.kvm20090303git.fc11 set to be updated
---> Package qemu-img.x86_64 2:0.9.2-0.1.kvm20090303git.fc11 set to be updated
---> Package qemu-system-x86.x86_64 2:0.9.2-0.1.kvm20090303git.fc11 set to be updated
--> Processing Dependency: bochs-bios-data for package: qemu-system-x86
--> Processing Dependency: etherboot-zroms-kvm for package: qemu-system-x86
--> Processing Dependency: vgabios for package: qemu-system-x86
--> Running transaction check
---> Package bochs-bios-data.noarch 0:2.3.8-0.6.git36989b0d2.fc11 set to be updated
---> Package etherboot-zroms-kvm.noarch 0:5.4.4-13.fc11 set to be updated
---> Package vgabios.noarch 0:0.6-0.5.b.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 301, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 253, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 363, in doTransaction
    lsts = self.listTransaction()
  File "/usr/share/yum-cli/output.py", line 929, in listTransaction
    a_wid = _add_line(lines, data, a_wid, txmbr.po, txmbr.obsoletes)
  File "/usr/share/yum-cli/output.py", line 907, in _add_line
    elif po.verifyLocalPkg():
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 664, in verifyLocalPkg
    (csum_type, csum) = self.returnIdSum()
TypeError: 'NoneType' object is not iterable
dhcp-lab-124 Download # ls qemu-*
qemu-common-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm  qemu-img-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm  qemu-system-x86-0.9.2-0.1.kvm20090303git.fc11.x86_64.rpm
dhcp-lab-124 Download # rpmquery -a \*qemu\*
qemu-img-0.9.1-12.fc11.x86_64


Version-Release number of selected component (if applicable):

yum-3.2.21-11.fc11.noarch

How reproducible:
always
Comment 1 seth vidal 2009-03-05 09:38:18 EST

*** This bug has been marked as a duplicate of bug 488673 ***

Note You need to log in before you can comment on or make changes to this bug.