Bug 488737 - Disable Plasma notifications for jobs
Disable Plasma notifications for jobs
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
http://aseigo.blogspot.com/2009/01/to...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 10:41 EST by Markus S.
Modified: 2009-04-28 12:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 12:17:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 338206 None None None Never

  None (edit)
Description Markus S. 2009-03-05 10:41:57 EST
I hope it's not too late for it to be included in Fedora 11:
Many new KDE 4.2 users at first don't get it that the progress bar for longer jobs (such as downloads) hides after a while. This can result in data loss when copying data between devices.
I suggest a simple fix:
Disable that Plasma takes over to show them and display the "old school" windows again.

Just add the following two lines to plasma-appletsrc:

[AppletGlobals][plasma_applet_systemtray]
ShowJobs=false

In KDE 4.3 the behaviour will probably be modified so this particular bug is only for Fedora 11.
Comment 1 Rex Dieter 2009-03-05 10:52:52 EST
The simple fix as provided is a per-user solution, not sure how to make that a global default yet.  

We probably should strongly consider this for F-9/F-10 too...
Comment 2 Kevin Kofler 2009-03-05 11:22:40 EST
Won't it work if we just stick this in kde-settings's plasma-appletsrc?

I think we should also consider ShowNotifications=false, as the systray notifications interact badly with KPackageKit.
Comment 3 Rex Dieter 2009-03-05 11:32:02 EST
fwiw, my initial testing was that ShowNotifications=false didn't affect Kpackagekit notifications, but maybe I just did something wrong.

Anyone else try testing this?
Comment 4 Kevin Kofler 2009-03-05 11:39:37 EST
ShowNotifications=false works for me. Maybe you didn't restart all that needs restarting for the setting to take effect?
Comment 5 Steven M. Parrish 2009-04-04 17:38:54 EDT
1 person says no, the other yes.  Can we get a consensus?  Does the ShowNotifications=false solve the issue and if so how soon can it be implemented?
Comment 6 Markus S. 2009-04-04 18:31:40 EDT
Whatever you do, you should implement it before Fedora 11 is final.
Has ShowJobs=false already been implemented? I don't run the beta of 11.
Comment 7 Ngo Than 2009-04-28 12:07:20 EDT
KDE needs restarting  after the change, it works for me too
Comment 8 Rex Dieter 2009-04-28 12:17:06 EDT
OK, looks like we've got persistent notifications working as of the latest kdebase-runtime builds:
%changelog
* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
- fix persistent systray notifications (#485796)


which mitigates the issues raised, here.  

For those that still want to diable the new stuff, you're welcome to use the aforementioned hack.

Note You need to log in before you can comment on or make changes to this bug.