Bug 488759 - Cannot run F10/F11 i386 guests without disabling ACPI
Cannot run F10/F11 i386 guests without disabling ACPI
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2009-03-05 11:58 EST by Daniel Berrange
Modified: 2009-05-21 13:06 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-05-21 13:06:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Boot log until hang (5.57 KB, text/plain)
2009-03-05 11:58 EST, Daniel Berrange
no flags Details
build log (215.92 KB, text/plain)
2009-05-21 12:55 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Daniel Berrange 2009-03-05 11:58:27 EST
Created attachment 334154 [details]
Boot log until hang

Description of problem:
Trying to boot a F10 i386 guest hanging somewhere around setting up IRC routing. If you disable ACPI it will work, but obviously that's not desirable for many other reasons.

Once it hangs, QEMU is totally non-reponsible, not even to new VNC connections, so seems to be live-locked, or stuck in some emulation never processing i/o from the VNC server

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Download  F10 i386  kernel + initrd from $OSTREE/images/pxeboot
2. Run

/usr/bin/qemu-kvm -hda /var/lib/libvirt/images/demo.img -kernel /root/vmlinuz -initrd /root/initrd.img  -vnc :1 -serial stdio -append "console=ttyS0"
Actual results:
Hangs initializing ACPI

Expected results:
Boots installer

Additional info:
Comment 1 Daniel Berrange 2009-03-10 09:35:39 EDT
I've hit this same problem with F11 guests too.
Comment 2 Glauber Costa 2009-03-10 19:38:00 EDT
should be working by now.

Please tell me if it's not.
Comment 3 Dominick Grift 2009-03-12 09:15:27 EDT
I updated to the latest available qemu on koji, restarted the qemu service. but still the same error here.
Comment 4 Dominick Grift 2009-03-13 10:42:58 EDT
Actually after a system reboot, i got another issue:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -S -M pc -m 2045 -
smp 1 -name mybooksdb2 -uuid a01adfdf-4016-f9b9-6b87-b0c48617c1ec -monitor pty -
pidfile /var/run/libvirt/qemu//mybooksdb2.pid -no-reboot -boot d -drive file=/de
v/sr0,if=ide,media=cdrom,index=2 -drive file=/dev/sdb2,if=virtio,index=0 -net ni
c,macaddr=54:52:00:2f:23:42,vlan=0,model=virtio -net tap,fd=18,script=,vlan=0,if
name=vnet0 -serial pty -parallel none -usb -usbdevice tablet -vnc -k
 en-us -soundhw es1370 
char device redirected to /dev/pts/1
char device redirected to /dev/pts/2
Could not read keymap file: '/usr/share/kvm/keymaps/en-us'

Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: char device redirected to /dev/pts/1
char device redirected to /dev/pts/2

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1485, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 973, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: char device redirected to /dev/pts/1
char device redirected to /dev/pts/2

Comment 5 Daniel Berrange 2009-03-16 08:36:14 EDT
Ok, this is finally booting F10/11 correctly in the build qemu-0.10-0.9.kvm20090310git.fc11.x86_64
Comment 6 Dominick Grift 2009-03-16 11:40:23 EDT
I can start a installation now but i have not been able to complete one yet. I've tried four times and each time it hangs on some point in the installation process.
Comment 7 Mark McLoughlin 2009-03-25 06:50:35 EDT
Think this was the fix:

* Tue Mar 10 2009 Glauber Costa <glommer@redhat.com> - 2:0.10-0.5.kvm20090303git
- build kvm's own bios. It is still necessary while kvm uses a slightly different
  irq routing mechanism

Presumably the plan is to resolve the differences ...
Comment 8 Glauber Costa 2009-03-25 09:57:49 EDT
Yeah, precisely.

However, this plan is not Targeted at F11. I don't see a drawback of using kvm's bios , tough.
Comment 9 Richard W.M. Jones 2009-05-21 12:53:57 EDT
Reopening ...

I don't think this is fixed.  I'm seeing qemu hanging like this

guest kernel  (NB architecture)

This fails running qemu inside Koji.  The x86-64 task here:

I will attach the build log.
Comment 10 Richard W.M. Jones 2009-05-21 12:55:50 EDT
Created attachment 344992 [details]
build log
Comment 11 Richard W.M. Jones 2009-05-21 12:57:31 EDT
I should add that the BIOS version is:

bochs-bios 2.3.8-0.6.git04387139e3b.fc11

I don't think this can be a BIOS mismatch because this
is using the latest package from F-11.
Comment 12 Richard W.M. Jones 2009-05-21 13:06:31 EDT
I've created a new bug for this: bug 502058

Note You need to log in before you can comment on or make changes to this bug.