Bug 488769 - (Noran) Emesene Trunk Crashes because of python's lock in threads
Emesene Trunk Crashes because of python's lock in threads
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 12:23 EST by Franck Waechter
Modified: 2009-05-28 18:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 13:01:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Franck Waechter 2009-03-05 12:23:53 EST
Description of problem:

Emesene Trunk Crashes because of python's lock in threads with message :

python: Python/pystate.c:612: PyGILState_Release: Assertion `oldstate == PyGILState_UNLOCKED' failed.
Aborted

it's working on others distributions


Version-Release number of selected component (if applicable):

python-2.5.2-1.fc10.x86_64 and emesene trunk.
Note : same crash in rawhide fedora 11


How reproducible:

Go to www.emesene.org and get the last svn trunk. Try to login, it crashes !


Steps to Reproduce:
1. Go to www.emesene.org
2. Get the last revision of trunk version (see wiki page)
3. Try to login, it crashes !
  
Actual results:

emesene crashes !

Expected results:

emesene must login without python's errors

Additional info:

See http://forum.emesene.org/index.php/topic,1853.0.html
Comment 1 James Antill 2009-03-05 13:01:08 EST
Which others?
How are the working vs. non-working python's compiled?
Are there any differences in the HW on the working vs. non-working machines?
What makes you suspect that it's a bug in our version of python?
Have you tried upstream python?

Realistically the Fedora python maintainers don't have the available time to debug other people's python code, sorry. So unless you have significant proof that it's our python at fault, then I'm going to assume otherwise.
Comment 2 Kyle VanderBeek 2009-05-28 18:41:41 EDT
This appears to be a emesene problem, not a Fedora one.  I poked around in the SVN trunk code, and PyGTK threads are initialized kind of late (by the Msnp object created on Controller.login().

The FAQ entry on PyGTK seems to indicate that you should do this before gtk.main():

http://faq.pygtk.org/index.py?req=show&file=faq20.001.htp

Note You need to log in before you can comment on or make changes to this bug.