Bug 488779 - Sound Preferences sets input level too high.
Sound Preferences sets input level too high.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 13:04 EST by Michael Monreal
Modified: 2009-03-19 11:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 08:17:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (62.68 KB, image/png)
2009-03-05 13:05 EST, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-03-05 13:04:51 EST
I wanted to test my microphone with pulse audio. It did not work. In the preferences, the slider was set to max. I checked alsamixer, which showed the level was 150%. Changing it there, it reset to 100% max. Tested, it works!

Sound Preferences should not offer to set the level higher than alsamixer would.

Note: I have checked the same using my usb headset. Input actually works with the slider set to max (>100% too) but the sound quality is very bad this way. Setting the level to 100% in alsamixer works best in this case, too.
Comment 1 Michael Monreal 2009-03-05 13:05:23 EST
Created attachment 334168 [details]
Screenshot
Comment 2 Bastien Nocera 2009-03-05 14:23:27 EST
If it sounds bad, it's PA's fault.

FWIW, it goes up to 150% thanks to this bug:
http://bugzilla.gnome.org/show_bug.cgi?id=567536
Comment 3 Michael Monreal 2009-03-05 14:48:55 EST
Shouldn't bug 567536 be fixed in the 2.25.92 gnome-media package that is in RawHide atm?
Comment 4 Bastien Nocera 2009-03-05 15:32:26 EST
And it is. I think you're misunderstanding. The fact that the volume goes to 150% for inputs isn't a bug, it's a feature. Read the upstream bug.
Comment 5 Lennart Poettering 2009-03-19 08:17:25 EDT
The PA and ALSA volumes are not directly related. PA's volumes are solely based on the dB information from the sound card. The result is that 100% in PA does not need to match up with 100% of the ALSA sound card.

I think this bug report is mostly due to a misunderstanding regarding how the volume values are related to each other. Closing.
Comment 6 Michael Monreal 2009-03-19 10:50:11 EDT
PulseAudio? ALSA? (In reply to comment #5)
> I think this bug report is mostly due to a misunderstanding regarding how the
> volume values are related to each other. Closing.  

Why would a user care how different parts of the linux sound eco system work (or even know they exist). If this is still the case => FAIL. I was hoping PulseAudio would finally fix issues like this...
Comment 7 Lennart Poettering 2009-03-19 11:56:38 EDT
We try to hide as much ugly stuff below PA as we can. But if you bypass PA then you will of course need to notice that there are certain differences between how PA and ALSA handles things. What did you expect?

Note You need to log in before you can comment on or make changes to this bug.