Bug 488801 - yum traceback during localinstall
yum traceback during localinstall
Status: CLOSED DUPLICATE of bug 488673
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 14:33 EST by Guy Streeter
Modified: 2016-02-09 20:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 15:23:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guy Streeter 2009-03-05 14:33:31 EST
Description of problem:
taceback while doing localinstall

Version-Release number of selected component (if applicable):
yum-3.2.21-11.fc11.noarch

How reproducible:
consistenly

Steps to Reproduce:
yum localinstall --nogpgcheck ...
  
Actual results:
$ sudo yum localinstall --nogpgcheck /home/streeter/redhat/RPMS/noarch/squeezeme-0.9-8.fc11.noarch.rpm
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Setting up Local Package Process
Examining /home/streeter/redhat/RPMS/noarch/squeezeme-0.9-8.fc11.noarch.rpm: squeezeme-0.9-8.fc11.noarch
Marking /home/streeter/redhat/RPMS/noarch/squeezeme-0.9-8.fc11.noarch.rpm to be installed
Loading mirror speeds from cached hostfile
 * rawhide: www.gtlib.gatech.edu
Resolving Dependencies
--> Running transaction check
---> Package squeezeme.noarch 0:0.9-8.fc11 set to be updated
--> Processing Dependency: python-simplejson for package: squeezeme
--> Processing Dependency: python-twyt for package: squeezeme
--> Running transaction check
---> Package python-simplejson.i586 0:2.0.7-2.fc11 set to be updated
---> Package python-twyt.noarch 0:0.9.1-1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 301, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 253, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 363, in doTransaction
    lsts = self.listTransaction()
  File "/usr/share/yum-cli/output.py", line 929, in listTransaction
    a_wid = _add_line(lines, data, a_wid, txmbr.po, txmbr.obsoletes)
  File "/usr/share/yum-cli/output.py", line 907, in _add_line
    elif po.verifyLocalPkg():
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 664, in verifyLocalPkg
    (csum_type, csum) = self.returnIdSum()
TypeError: 'NoneType' object is not iterable


Expected results:
package installed.
Comment 1 seth vidal 2009-03-05 15:23:14 EST

*** This bug has been marked as a duplicate of bug 488673 ***

Note You need to log in before you can comment on or make changes to this bug.