Bug 488822 - ISE when viewing packages that need upgrading but have no errata
ISE when viewing packages that need upgrading but have no errata
Status: CLOSED DUPLICATE of bug 486982
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2009-03-05 15:38 EST by Mike McCune
Modified: 2009-03-09 16:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 16:33:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stacktrace (12.23 KB, application/octet-stream)
2009-03-05 15:38 EST, Mike McCune
no flags Details

  None (edit)
Description Mike McCune 2009-03-05 15:38:11 EST
Using rhnpush do the following:

* Create a system that is RHEL5.1 
* Create a channel that has RHEL 5.2
* Create activation key for 5.2 channel
* Register said system to Spacewalk using activation key
* GUI should show that your system needs upgraded packages since channel is newer than 5.1
* Try to click on the # of packages needing upgrades from the "Packages" column on:

https://<spacewalk>/rhn/systems/Overview.do 

Should take you to:

https://<spacewalk>/rhn/systems/details/packages/UpgradableList.do?sid=*****

This causes:

Caused by: java.lang.NullPointerException
	at com.redhat.rhn.frontend.dto.UpgradablePackageListItem.getErrata(UpgradablePackageListItem.java:107)
	at sun.reflect.GeneratedMethodAccessor338.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

Full dump incoming.
Comment 1 Mike McCune 2009-03-05 15:38:50 EST
Created attachment 334207 [details]
stacktrace
Comment 2 Brad Buckingham 2009-03-09 16:33:29 EDT
This BZ is a duplicate of bz 486982 and a fix has already been submitted.  Ran tests with the latest code and was not able to reproduce the issue.

*** This bug has been marked as a duplicate of bug 486982 ***

Note You need to log in before you can comment on or make changes to this bug.