Bug 488824 - Fedora 11 Feature, KMS, does not work with Intel Mobile 915GM/GMS/910GML Express
Fedora 11 Feature, KMS, does not work with Intel Mobile 915GM/GMS/910GML Express
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 513462
  Show dependency treegraph
 
Reported: 2009-03-05 15:51 EST by Peter Gückel
Modified: 2009-09-19 14:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-19 14:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Xorg log from the failed attempt (7.67 KB, text/plain)
2009-03-05 15:51 EST, Peter Gückel
no flags Details

  None (edit)
Description Peter Gückel 2009-03-05 15:51:06 EST
Created attachment 334209 [details]
The Xorg log from the failed attempt

Description of problem:
When I remove vga=0x318 and nomodeset, leaving just rhgb, on the grub kernel boot line, the laptop boots, but there is no plymouth display, the computer sounds like it is loading the system and would appear to be auto-logging into KDE, judging by the sound of the drives, but the screen is black and the display is locked, that is, I cannot change to another VT (ctrl-alt-fX does nothing).

Version-Release number of selected component (if applicable):
2.6.29-0.179.rc6.git5.fc11.i686.PAE
Intel Mobile 915GM/GMS/910GML Express

How reproducible:
Remove the disabling kernel boot parameters, leaving the defaults (ro quiet rhgb), to presumably enable KMS, then boot.

Steps to Reproduce:
1. as described above
2.
3.
  
Actual results:
A black screen results and there is no way to change to a console VT, or even to reboot (except Alt-SysRq).

Expected results:
KMS should work. There should be an X display and Plymouth should show its graphical login.

Additional info:
I am not sure what the display's native resolution is. With KMS disabled, the maximum display resolution is 1024x768. I think the true display resolution is supposed to be 1400x1050. I have tried entering this information for a new modeline into xrandr, but it didn't work.
Comment 1 Peter Gückel 2009-04-01 13:06:03 EDT
What, actually, has been done on this bug, now that we are in F11beta? It still doesn't work.
Comment 2 Peter Gückel 2009-04-10 12:41:55 EDT
It still doesn't work on Good Friday. Not at all. Just a black screen.
Comment 3 Peter Gückel 2009-04-14 12:25:02 EDT
How do I set the priority in this. It is set to low, but that is incorrect: it is supposed to be urgent.

There is still no improvement. It simply does not work.
Comment 4 bobpoljakov 2009-05-17 09:00:47 EDT
For me, KMS works well with the standard kernel, but with the PAE, it only shows the text plugin, with the correct resolution, and then only a blank screen with or without xorg.conf, with vesa or intel driver. Xorg.0.log shows no error. 

The VGA controller: 
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
Comment 5 'j 2009-06-06 06:23:32 EDT
I don't know what is KMS but i have appearingly the same problem : no graphical boot neither shutdown since i switched onto Fedora 11 Rawhide(everything was fine before).

Sometimes the [OK] prompt appears at shutdown for a few lines before it turns black.

I thought this would be related to X.

VGA/Display :
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Comment 6 Bug Zapper 2009-06-09 07:56:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Peter Gückel 2009-09-19 14:30:46 EDT
As of yesterday, with the new Mesa, kernel, x server and intel graphics driver, as provided by the rawhide repos, this finally works on both my desktop and laptop computers.

Note You need to log in before you can comment on or make changes to this bug.