Bug 488828 - switch user (under gnome) causes display, keyboard to lock; must restart with power button
switch user (under gnome) causes display, keyboard to lock; must restart with...
Status: CLOSED DUPLICATE of bug 484516
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 16:06 EST by Need Real Name
Modified: 2015-01-14 18:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 08:18:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-03-05 16:06:36 EST
Description of problem: Under gnome (kde not tried), when a user is logged in and tries to switch to another user (whether from menu "system-log out <user>", from the applet, or when the screen is locked by screensaver), the display starts to return to the login screen but only displays a partial view of it.  The keyboard doesn't respond, the mouse cursor is visible and cursor tracks but no clicks work.  So it's impossible to do ctrl-alt-f2 or ctrl-alt-backspace, etc.  The only alternative is to turn the machine off with the power button or login remotely (e.g., via ssh) and give the reboot command.


Version-Release number of selected component (if applicable):
  gdm-2.24.1-4.fc10.x86_64
Not sure if this is really the culprit.  It's an fc10 system with all updates installed.


How reproducible: 1. Login as a user, under the default setup with gnome.
   2. Click on switch user in any menu it appears in.

Steps to Reproduce:
1.Login
2. Click on switch user
3.
  
Actual results:  display and keyboard lock, mouse cursor tracks but clicks have no effect.  Remote login via ssh still works.  To restore any local access, the machine must be rebooted.


Expected results: switch user works, and works repeatedly


Additional info:
Comment 1 Ben Liblit 2009-05-31 02:56:16 EDT
This may be a duplicate of #484516.  If someone with DUPE-marking power agrees, I recommend that this bug be marked as a duplicate and that #484516 be retained, as #484516 has more detail.
Comment 2 Devendra Gupta 2009-06-03 17:17:52 EDT
I have the same problem but my my machine architecture is x86-32 (i686), and my kernel version is 2.6.27.24-170.2.68.fc10.i686
Its fu
Comment 3 David Juran 2009-06-04 08:18:35 EDT
Agreed (-:

*** This bug has been marked as a duplicate of bug 484516 ***

Note You need to log in before you can comment on or make changes to this bug.