Bug 488833 - Fedora 10/11 cannot read EEPROM on Cardbus Ethernet Controllers on Dell D630
Fedora 10/11 cannot read EEPROM on Cardbus Ethernet Controllers on Dell D630
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 513462
  Show dependency treegraph
 
Reported: 2009-03-05 16:29 EST by Jeff Weston
Modified: 2010-06-28 07:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
zip of text files containing output of lspci, dmesg upon insertion of Netgear card in various Dell Latitudes, including the D630 in Fedora 10 and Fedora 11 (5.12 KB, application/x-zip-compressed)
2009-03-05 16:29 EST, Jeff Weston
no flags Details

  None (edit)
Description Jeff Weston 2009-03-05 16:29:05 EST
Created attachment 334212 [details]
zip of text files containing output of lspci, dmesg upon insertion of Netgear card in various Dell Latitudes, including the D630 in Fedora 10 and Fedora 11

I have some Dell Latitude D630s running Fedora 10, and I'm trying to use Netgear FA511 and/or D-Link DFE-690TX PCMCIA ethernet cards on them.  However, with both cards, it is unable to read the EEPROM.  For the Netgear FA511 cards, this results in an interface that does not send/receive packets (not even in tcpdump on the local machine), and the interface has the well-known "tulip driver can't read the EEPROM" MAC address of 00:4C:69:6E:75:79 ("Linux" in Hex). For the D-Link cards, the behavior is not quite the same, but at any rate, it doesn't appear to be able to read the EEPROM either (all 0's MAC address, when I was able to get the interface to come up).

The same cards work fine with the same OS (Fedora 10) on other Dell laptops (Latitude D600 and D800s, which have a different CardBus controller). Additionally, the card works fine in the same exact machine if I install the Fedora 11 alpha, or if I boot from an Ubuntu live CD (running a very similarly-versioned kernel). I've tried updating the BIOS and the OS, to no avail.
Comment 1 Jeff Weston 2009-03-30 12:51:29 EDT
This bug is very important to us -- the machines are worthless without the additional interface.  It also shouldn't be that hard to fix, since it's already been fixed for Fedora 11...
Comment 2 Jeff Weston 2009-06-16 12:32:22 EDT
So it worked in the Fedora 11 Alpha, but it's busted again in the Fedora 11 Final release.  What's the deal?
Comment 3 Jeff Weston 2009-09-16 08:23:48 EDT
Still busted in the latest Fedora 11 kernel...
Comment 4 Anup 2010-01-23 14:50:38 EST
I am also facing similar issue with a proprietary PC Cardbus wireless device. My driver is not able to read the EEPROM. Any clue on which kernel does this work...
Btw, I tried with 4.6.24.fc8 and 4.6.29.fc11. No Luck. Any idea??
Comment 5 Bug Zapper 2010-04-27 09:07:06 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2010-06-28 07:24:24 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.